Troubles connecting to the T3-BB

New T#-BB out of the box powered up and connected to PC will not connect and cannot ping controller PC is set to same subnet ( beat light is erratic, not consistent 1 pulse per second.

Im sure someone smarter will chime in but I dont think you can connect directly to a computer with an ethernet cable unless its a crossover cable. SOME devices can… I dont know if BB can or your PC for that matter. You may need a network switch between the two devices.

That said… they absolutely cannot be on the SAME ip. You need to have the BB on say and the PC on subnet mask should be on both.

Definitely right on all counts David, with one small clarification I can add on the crossover cable. Most laptops & PC’s these days have an auto crossover detect function in the Ethernet chip. The T3 devices dont have it with the current hardware so with an older PC you may have to use the crossover cable.

When we finally get into production in a month or so with the new Ethernet chip it will support crossover on the T3 devices as well.

1 Like

They are not the same IP and I tried direct and through a switch with no luck.

Can you share the IP settings for both the T3 device and your PC please.
Make sure all programs and especially, some sneaky services which might occupy the 47808 bacnet port are shut down.

Shut down all VPNs if any. – T3 - PC

Need a little more info than that. Am interested to see the subnet settings and to verify that all other wireless adapters, vpn connections are shut down to simplify the routing as much as possible.

Sometimes we can see routing issues by looking at the routing table. Use the “route print” command from the command line. Here we can see all my VPN connections and the wireless adapter are indeed turned off.

As a last resort you can connect to the device using the RS485 port. T3000 will scan and discover it so that you can get to the advanced settings page and check the IP settings there. T3000 will discover the device no matter what protocol or baud rate you have the RS485 currently set at, it will scan using both Modbus and Bacnet at all possible baud rates.

See attached. Is it common for these controllers to be difficult to connect to? All of my experience has been with Siemens and Andover, decided to try this out
as an alternative.

I just learned our crew is shipping with the default IP address to a static IP, this is a poor assumption obviously and I’ll sort that out pronto. I also see your network uses a large netmask, we’ve made some improvements in this department but the firmware on your device will have to be updated. Please update the firmware using T3000-> help -> check for updates once you do manage to connect using one of the methods below.

Direct Connection Method: Connect directly to the device with an unmanaged hub or direct cable connection. T3000 will be able to scan and connect over Ethernet.

RS485 Method: Connect your PC and just the one device over RS485, scan with T3000.

We put a lot of effort into making our products plug and play as much as possible. Have you tried connecting by RS485 just for the initial connection? T3000 can discover the device no matter what the baud rate or protocol happens to be set at right now. As always, isolate your test setup to the simplest possible configuration as possible: one PC and one device, other networks and devices are isolated from the test.

I got an RS485 to serial adaptor and it connected. The Ethernet still will not work. I tried with a direct connection and with a mini hub just connected to my

Make sure all VPN and wifi connections are turned off temporarily.

Make sure both your PC and the T3 are on the same IP network, if you’re testing off the local LAN you may need to manually set the IP address of your PC since the DHCP server in your office will not be able to assign an IP address.

Make sure to update your T3000 software: T3000 -> help -> check for updates.

You can also update the device firmware over the RS485 port, you will need to set the protocol to Modbus temporarily to do this. T3000 can connect to the device on both Modbus and Bacnet but I just learned from my crew that we don’t have Bacnet RS485 updates working on the T3 series. Its on the todo list.
When connecting over the RS485 port you can see the network settings, please show us the IP settings for the device and your PC like below.

We can log in via teamviewer and help out, just email us and we’ll set this up.


I’ve done all of this. Set the laptop for static IP, set to the same address space as the controller, turned wifi off. While connected via RS485 tried building
a digital output point following the manual, was unsuccessful. Tried to create a program, received error that program grid doesn’t exist. Tried to connect again this morning and during the scan it says garbage data received. How can I return this order?

Could you send us an email to coordinate a teamviewer session to your PC. I am sure its some small little setting or parameter that needs adjusting. We will use some networking tools and get to the bottom of this,100% confidence level.

Update2: We tried to log in on your Teamviewer and it appears the PC is offline. Best to continue this discussion by email. I will post the results on the forum later.
Update1: We updated T3000 so you can do firmware updates over the RS485 port, tested and working on the latest version of T3000 & T3 firmware.

Original Reply:
Best not to put this kind of Teamviewer credentials on the forum, edited them out for you.

Logged in and was able to see you are connected over RS485, edited the IP settings to match your PC but still cannot manage to connect to the T3 controller as you have been experiencing. I’ll have an engineer look at this in their morning/ USA evening.

We’re connected over COM4 using Modbus protocol. One thing I noticed, the panel ID at Tab2 doesn’t match the panel ID showing at Tab1. I updated the T3000 front end and the communications are more stable now than showing before at Tab4. I wasnt able to update the device firmware over the RS485 port for some reason.

Main issue: the ethernet scan still cannot discover the device which could have something to do with being connected through two routes at the same time. You could disconnect the COM4 connection, cycle power to the controller, then try over the Ethernet connection again.

I have forwarded this info to an engineer and they will log in shortly.

1 Like

7 posts were split to a new topic: Certain Routers have trouble communicating with T3