General troubleshooting and learning

Hi guys,
I have had a LOT of issues updating the firmware on a Tstat8 over MODBUS from a T3-BB and T3000. I have bricked and had to recover this thing more times than I can count. Typically if the device is actually functioning, it’ll start the update, the screen on the Tstat will show UPDATING, and then either T3000 or ISP tool will say Initializing, Erasing, and then kick out an error, usually something along the lines of Write Flash ID = 9 To - 128*2048, then I click OK and it says Update was interrupted. The Tstat will stay in Updating forever until I reboot it, then it gets stuck in ISP mode. Further attempts at updates almost always end the same way. I’ve tried taking the Tstat to the T3 and connecting them with a short length of cable to eliminate building wiring issues and have tried a variety of baud rates. The only consistent way I’ve found to get the thing to function again after a firmware update gone awry is to connect the two on a short length of cable, physically pull power from both units, plug them back in, then run the update while the Tstat is in ISP mode, which is a real pain. The T3 updates no problem. What am I missing here?

1 Like

I have noticed poor comms on Modbus Subnets lately as well.
All points well taken and we’re on it.
Maurice

Is these comm issues on just the Tstat8 or all products?

OK, the team has pushed out a new version of the T3000 front end which you can download by going to T3000 -> help -> update T3000. Once you have done that you will be able to load new firmware to main and subnet devices normally.

Hi Maurice,

Do you have a list of issues the firmware update addresses?

Thanks

Ken Rackowski

The firmware wasnt updated to fix this, just the T3000 front end needs to be updated. In general you can see the firmware or T3000 update notes as you do the update, there’s a page which pops up and shows all the recent changes/fixes/new features.

The firmware update system itself is undergoing an update, we’re working on serving up data sheets, program libraries, cad files and so on via the T3000 front end soon.

MD

1 Like

I have been running into the same problem. I’m on an out of town project right now and I have 3 Tstat-8 stuck in ISP mode. When I ran into this when I was in town, I tried the same thing on my lab gear. I kept getting the interruption error when using a Tiny Brother and Little Brother but when I used the Big Brother I was able to update the Tstat. I haven’t been able to update Tstats on a job site now for about a month.
My T3000 software is the most current also.
Bret

1 Like

No known issues about this other than the old issue where one rev of the T3 controller firmware could not update subnet devices. The fix is to make sure you have the latest firmware in the T3 controller itself.

If you cannot reach out to recover the stat over the T3 subnet you’ll have to temporarily take it offline and conect directly over USB/485 direct to the stat, then do the cycle power -> flash with ISPTool in the first few seconds after power up.

1 Like

There are two RS485 ports on the T3 controller, confirm the Tstat8 and T3 controller are set up correcly at the same baud rate and protocol. If Tstat8 is stuck in ISP mode, T3-BB/LB/TB can not identfty Tstat8 automatically, you’ll need to manually set correct port, protocol, baudrate and hopefully you know the ID.

If one of the RS485 ports of the T3 controller is not in use be sure to set it to unused otherwise it will spend time polling and trying to auto discover devices.

You can reach a device on a T3 subnet that is stuck in ISPMode if its in Modbus protocol, if you’re working in Bacnet you’ll have to take the device off the RS485 network to isolate it from other devices. Connect directly over RS485 with one device to the PC running the ISPTool and recover it by cycling power and flashing in the first few seconds after power up.

image

1 Like

I made sure all settings were correct. The update always starts but then has a comm issue and stops. This is on 5 different controllers in the field - and in my lab, only the BB can do the update? I never used to have this issue. I’ll update you when I get back to town and try updating these t-stats via my office gear.
Thanks for your help! :slight_smile:
Bret

Thanks for the feedback Maurice. I’ll try these when I get back to my office…I’m out of town now.
Bret

I just had the Jan 11 t3000 versión running and attempted to get the update done on the tstat8 via modBus and it appears to only write a couple blocks and says update complete yet the tstat is flashing update. When I power cycle the tstat it just has a flashing screen. Same thing happens with my co2 temp sensor. Now all devices are down and not working.

[Admin: Removing links to external movie files]

Thanks for all the screen shots and movies, I checked them over but am cleaning up the dialog a little for clarity.

I saw the firmware update issues here and we’ll be working on making things go smoother and be more intuitive with the messages it sends out in the next release which is scheduled for right after the local break, Feb2. In the mean time the workaround is to take the devices off the network and complete the firmware update with a one-to-one connection to your PC. If you have trouble connecting you can usually have more direct results by cycling power and updating in the first few seconds after power up. If you are not sure of the device ID you can flash to ID=255 which is the global broadcast ID but be sure to do this with only one device connected at a time. The procedure is described in more detail in the ‘Unbricking a bricked device’ thread.

1 Like

Hi @maurice,

I was able to get the devices back online. Thank you for tour help and guidance here.

I have changed the protocol to Bacnet and changed the communication speed from 19200 to 56700 to see if the devices respond faster. I find that the t3000 program can not keep up with the speed change. I am just bench testing these devices so the wiring is only a couple feet at most.

Do we need to add 120ohm terminating resistors to the Communication loop?

Also I can not see the temp sensor as a Bacnet device when I perform a “who-is”

Temp Sensor: Not clear what you mean… send a little more info and I will make suggestions.

Terminating Resistor: The 120 Ohm resistor is not normally required but it doesn’t hurt to try if you’re having issues. I can suggest having a digital scope around if you will be doing a lot of connecting with RS485. There’s a decent one on the temco/bravo web store.

1 Like

The co2 node does not show up as a Bacnet device outside of T3000. The Who-is command does not return the device instance, but does return the tatat8 information and controller information.

I can not upgrade firmware while in Bacnet mode.

I changed a tstat8 from Bacnet to modbus while the device was connected to the Bacnet channel and it accepted the change.

I then ATTEMPTED to changed the co2 node from Bacnet to modbus but it wouldn’t communicate with the node.

I then changed the channel from Bacnet to modbus on the controller.

After that, I am not able to reconnect to the tstat or the co2 node.

I restarted the controller- nothing.

What next?

If there are other devices connected to your network that will definitely have an effect on the communications, so would be helpful to know the full network setup situation.

If its just a single device connected to your PC over RS485 then T3000 ‘should’ be able to pick it up no matter the baud rate or protocol you have set it to. There could be complications if you have set the parity and stop bit settings, T3000 only scans with N8E1 which is the default.

Standing by to help.

Only the two devices mentioned in the post are on the network.

Controller----> co2 node—> Tstat8

The tstat8 is connecting with errors and says it doesn’t have a configuration.

Is there a way to “reboot” the tstat remotely, similar to how you can restart/reboot the controllers?

All right then.

Since you are having troubles then you can disconnect one device till things have settled down. Once all is clear you can try with more devices.

The notice about ‘doesn’t have a configuration’ is just a message saying the device doesn’t have a dialog for that particular feature. It pops up when you click on OUTPUTS for example and the device doesn’t have outputs. I will make a note to the team to push a better message.

I am not sure off hand about rebooting controllers but most devices do have something. It would be in the advanced screens under the gear icon.

Here is what happened with 2 tstat8 I tried firmware updating
[Admin] Updating firmware over the RS485 subnet via Ethernet connection to T3-XX controller.

image