T3-OEM Lost communication

I’ve been configuring a T3-OEM for a custom application. I was attempting to change the LCD display parameters to something that fit my application and the controller crashed, rebooted and now I’m unable to connect RS485 or WIFI to the T3000 software. Tried to do a power cycle/firmware flash, it succeeded but didn’t reset the corrupt program to default.

The LCD BACnet MAC, BAUD and Protocol configs are correct, tried Modbus as well without luck. Any suggestions? Previously the BACnet 485 and WIFI worked flawlessly. When I run the scan it detects BACnet but not my single device at MAC-10.

Any suggestions?

Please search this forum for ‘unbricking a bricked device’. Basically you cycle power and flash using T3000 → tools → flash single device. You need to do this in the first few seconds after power up when the device is in ‘ispmode’ with the LCD or heartbeat LED flashing with two blips, pausing, then repeating the two blips. This happens every second or two in the first ten seconds or so after power up.

Let us know how it went.

Maurice, thank you.

I did find the instructions before my original post and have already tried the unbricking procedure twice. Strangely it seems the program file remains loaded after the firmware flash.

Once it finishes I’ll verify the Mac, Baud and protocol via the LCD and run the scan. I’ve tried changing these as well and cannot connect.

I would reload the program after flashing, just to be sure. Thanks for working through this with us.


That would be my next step. Unfortunately I can’t connect in order to do so.

When performing the firmware flash my USB to rs485 works so I know that’s functioning.

I’m thinking somehow the MAC address register was somehow corrupted with something other than a number like a character of some sort?

I noticed previously after a crash the WI-FI SSID would no longer function. When reconnecting RS485 to check the config the SSID would have an Ethernet Mac in the field. For example SSID: TEMCO would show TEMCO 1a:2b:3c: etc.
Once I cleared the garbage data the Wi-Fi would auto configure again.

Forgot to mention, using the MODBUS tool I can connect and see RAW data, but I’m not familiar with navigating in this mode.

Is there any way to clear the controller memory by jumper or shorting two pins?

You can connect with our team to troubleshoot.

More below:

No pins but we have this:

Maurice, thanks.
I cannot connect to the controller with the T3000 software, therefore I cannot access the “clear controller” button.

Understood. So… hopefully the device is doing the two blips on the backlight, repeating every second or so after power up. If not the device will need to be checked out on the bench here.

Assuming the device is going through the bootup process, you will need to get a firmware image, hopefully you have that from your earlier debugging. If you have a working device there you can use T3000 → help → check for updates → download firmware, this will store a copy of the latest & greatest firmware for the device on your hard disk. If not hopefully you can locate it here:
Index of /ftp/firmware/.

Once you have the firmware you can connect over RS485 with a known good cable and known good USB converter, cycle power to the device and hit the ‘Flash’ button in the ISPTool. Connect to only one device at a time when doing this. If you cannot revive the device following these steps then we can help out remotely, send us an anydesk invite by email and we’ll organize a time to assist.


All the above has been completed and the issue remains. I have MS Teams, If you like I can send in invite for remote support?

Sure we’re standing by to help. please send a link by private message.


Sent you an invite, Teams is open and waiting.


We can tray again another time, I didn’t see anybody join. I had to move on after 30 minutes. The only way I can partially connect is if I cycle power to the controller. I’m able to see some communication settings but there seems to be a few issues.

The device in the screenshot is set up as Modbus/19200/MAC#5 via the LCD.
Some of the fields are blank or greyed out. See below:


I ordered a Tstat10 and T3-TB to test. Please let me know how to get this T3-OEM replaced or returned. Thank you!

It sounds like you would like to swap equipment with us, you can do that by email.

I think you are not in fact connected to the device. Check down at the bottom of the screen where the communication health is showing. That’s your best bet to see if you are connected or not there. This area may be hidden from view if you’re on a smaller resolution screen, you’ll have to try from a different monitor as our T3000 wndow is not scaleable.