Trouble in Connecting to T3-BB & T3-TB (Controller goes offline)

We are experiencing communication failure in both T3-BB & T3-TB over Ethernet. Controller goes offline after 2-3mins of the initial connection with the Laptop and comes back online only after 10-15mins but suddenly goes offline again.

We have tried grounding of controllers & cross cable option too but no success so far. Updated the T3000 software but unable to upgrade controller firmware since we can not make a stable connection to the controller. Further we tried to establish the connection over RS485 but it is not working totally.

This particular order contained more than 10nos T3 controllers and every controller show the same issue. (The test controller that we ordered about 8 weeks ago (T3-TB) worked fine and still connects with the laptop without any issue)

Could you send me a program or two from the controllers. One thing folks are having trouble with us infinite loops in the programming. All programs need to flow through to the last line each scan. The will restart again at the beginning automatically.

Maurice Duteau

We haven’t uploaded any program yet since this was experienced during the initial set up! We just tried to rename few objects first but can not do it continuously since the controller goes offline after few mins. However the few objects that we managed to rename before it goes offline can be seen when the controller is back online after 10-15mins.
(We just plugged and checked another T3 without working inside the controller and issue was the same)

Further, we tried both the option, connecting the controller with default IP and with a new IP assigned. FYI, we can not ping the controller when it goes offline.

Note: The test controller that was ordered before is working fine on the same setup.

Max, I feel your pain. I am the veteran of a lot of trouble connecting to T3’s via Ethernet and have tried a ton of things. Maurice continues to be Temco’s best asset and he has been more than patient with me as I navigated the issue. At first I refused to believe that different Ethernet switches could have an effect. But it can happen. And I can’t prove it, but I think the fact that the T3’s have only a 10mBit ethernet port doesn’t help any either. We have 4 T3-LB’s on our network and we still have the occasional communication drop out. Infrequent enough to make them still viable and at their price, cost effective; but often enough to make it a pain in the neck and an important programming consideration.
Here’s my suggestion. Connect your T3 directly to the PC running the T3000 software using a crossover cable. If you can communicate reliably then you know one of your Ethernet switches is not tolerating the T3 very well, or something else on the network is impeding the communication. My best gauge is to ping the IP of the T3. If you can get 20 for 20 good pings, you’re OK. Perfection is 100 for 100.
Hope this helps.

1 Like

Could you share a few screenshots please, and the program in the controller.

Maurice Duteau

Thank you @tdawgtoo for your inputs!
We have already connected T3 directly to the PC using crossover cable. And we can not ping the T3 at this moment.

Screenshots:
Here are some screen shots. FYI we have tested the controller health and it is something around 20% (Meanwhile, the T3 which we purchased for our test bench in an earlier order and connects without any issue, shows 100% health)
Note:
We can arrange a remote connection for you to access our PC anytime.
And we have now updated the controller’s firmware too.

Program:
We haven’t uploaded any program to the controller yet.

New issue:
Meantime we noticed another issue in the same T3-BB controller as it is restarting automatically after sometime with blinking LEDs which are dedicated for Inputs & Outputs.

1 Like

I had same issues in my current installation. Then i work with controllers i run ping to each controller from pc and then after some time network becomes stable.

My old installation works without any issues however. It was unstable at first, but now all is fine. I tried different switches, cheapest ones works best for me :slight_smile: (Netis unmanaged 100mb). Also PC is connected to it all the time, network rooter is Tosibox. Network works on static IP.

2 Likes

Thanks @andrius your support is highly appreciated as we are in a huge trouble.

Unfortunately we couldn’t even rename the Inputs/Outputs or load the program to the DDC as it went offline after 2-3 mins from the initial powering up. No switches in between the Laptop and T3 and we are using the T3000 software. Can not connect over RS485 as well.

The other controller which is from the last shipment works fine. Any ideas or advices would be greatly appreciated! Thanks!!

1 Like

Try pinging controller constantly, this helped in me case. All controllers are working fine till ping is on for all of them. I have network of 5 T3TB, so i have 5 windows with ping running.
image

1 Like

I would clear the panel, update the firmware and t3000 front end, make sure only one sub network is set to rs485, load your program and turn the programs all off. Then enable them one by one.

As you work, keep an eye on the communications health at the bottom status line.

Standing by to help.

Maurice Duteau

We are trying only one T3 at once, connecting it to Laptop without using a cross cable and no switches in between.
Can not ping the T3 and no response from the DDC.
Any ideas @andrius ???

@maurice
Confused!! What do you mean by the program here? As I mentioned several times we haven’t loaded any programs yet.

Controller is almost fresh but no communication with my Laptop (over Ethernet/RS485) and this is the issue. Pls address the real issue, all the measures that we have tried are mentioned above.

we may have to get the unit back for a check over. Send an email and I will coordinate with you.

Maurice Duteau

Just wondering how many devices are powered off of the power supply? Could it be a voltage issue? It’s odd to see the network port not be alive and stable. Can you change the IP of the device? Does it stay “alive” long enough?

Only one device @bill
And this could not be a power issue since the other controller works fine on the same set-up
Thanks for your inputs.

2 Likes

I purchased our first T3000 controller as a test item and have experienced the same issues,

Severely disappointed to say the least, I stuck my neck out looking for a replacement for the product we currently use

Btw I’ve had nil response from Temco

Unless they sort the shit out, the product won’t sell

Haven’t seen any emails from you Michaelg. I stand behind my product and am ready to help out. Send on details and we’ll get you up & running pronto.