T3-LB Controller Writing Error

Hello!
I had a problem with the Temco T3-LB-WIFI-1kPT controller with the latest firmware “mini_arm_rev50.0_11.15.hex” - when I try to write changes to the controller they do not happen, see the video: https://youtu.be/qfqXp2cXbv0
This situation happens when I try to write the values of variables as well.
What is the reason? If necessary, I can send you my program by e-mail.

In general its always best to use the latest firmware, you can download that by going to T3000 -> help -> check for updates.

There were some reports of communication issues with the wifi version products, best to use the latest T3000 front end also also the latest firmware. If you have trouble over wifi try over the wired and RS485 ports, could be that we have more work to do to make the wifi more reliable.

Standing by to help if problems persist after you do the updates.

Hi @maurice,
I use latest T3000, latest T3 firmware and only wired connection, LAN and RS-485.

Aleksei

Ok could you show me a few screen shots from t3000 front end. Once you verify from there then when progress to writing from an external modbus master.

The auto/manual software setting can catch you up if you are not familiar with that. Using T3000, make sure all the io are in AUTO!

Maurice Duteau

@maurice, T3-LB is a Modbus master in this case and polls the slaves, I can send you a program so that you can see everything for yourself.

UPD
I made a video for you as I try to change the values of two local variables of the T3-LB controller. This is a common switching variables without any logic, see: https://youtu.be/rmhzb_JD_bw

Send on your program and we’ll have a look. You can email to chelsea (at) temcocontrols.com. That’s quite a detailed display you built up there, looks nice.

Hi @maurice,
I sent @chelsea a program and video from this topic by email.

All right, we are working on this now.

Hi Aleksei,
I checked your video and program.

  1. communciation issue when com port is master, I downloaded same monitor tool to test what you said, but not redupliate your issue. The bytes are continuous.
  2. Write Error
    T3000 already fixed this issue, it is caused by reading too many points in one graphic and stucked. when you upadte latest T3000, it will be ok.
  3. Program code is turn off automatically.
    I loaded your prog, I guess T3-XB is too strict to check runing time of every program. I should do someting to avoid it. If it exist dead cycle, it will jump out, so the prgrom can not running correct, and generate an alarm. If the program just runing too long time by accident, it will generate an prgram alarm too. You can turn on it by hand. I will upload a new firmware to subdivide the two error.

@chelsea, thank you very much for your reply!
On the first point, everything is OK, there is no problem.
On the second point, the problem remained after the T3000 update, see the video: https://www.screencast.com/t/qkUTsDW1Nad

Please pay attention to the incorrect display of labels of some variables, for example: “Actual Comp. Freq” is 1200 and “Compr. Mode Status” is Label Invalid. The values of these variables are set in the unit table under the numbers 64 - Hz and 65 - State. But on the chart they are not displayed properly. See my program.

The second point and invalid label will be fixed in latest T3000, our PC programmer will release it today.

Hi!
Inexplicable things began to happen to my T3-LB controller: after turning on the power, initialization is performed and after it the controller does not indicate external connections, there is no indication of activity via Ethernet, RS-485, UI and UO, while the controller does not respond via Ethernet and does not see the connected PT1000 sensor. See video: https://www.screencast.com/t/SpymyWOsH7
After turning the power off and on again, from the tenth time, the controller may start once in normal mode.
There is no program in the controller, T3000 and firmware of the latest version.
What could it be? Please help.

Haven’t seen this behavior before. Send us your program if you could and we’ll try to duplicate it in the office.

Hi @maurice,
There is no program in the controller. When such strange inclusions began to occur, the first thing I thought was that there was something in the program and I reset the controller, but that did not help. An interesting fact, after initialization, when the controller does not start in normal mode, when manually turned on DO, I hear the relay click, but the LEDs do not light up.
Today I was able to start the controller with the sixth attempt.

1 Like

Really haven’t seen behavior like this before. I assume you have tried reflashing the firmware already in which case it sounds like the bootloader itself has become corrupt. Could you send us an email privately and we’ll arrange to swap your controller.

Rev50.1_11.29 fixed it.

1 Like

Hi @chelsea,
I updated the controller firmware to the latest one that you posted today, now the controller always turns on as it should. It looks like the problem was in the firmware.
Many thanks!

1 Like

It remains to finish the T3000 :slight_smile:
With the new firmware, when I tried to add Hz and State (64 and 65 positions) to the units - the controller started to reboot :frowning:

I tested those range settings but was not able to reproduce the issue. Standing by to help more once you send more info.

Hi @chelsea,
I’m writing a program for the T3-LB controller. Unfortunately, I encounter a constant reboot of the controller when I try to change the value of any variable, this sometimes happens on the first try, sometimes on the second or third, but it happens all the time. Watch the video in which I ping the controller. The controller stops pinging when it restarts: https://www.screencast.com/t/mbi1iUyiYA
The firmware in the controller is the latest, the T3000 is also the latest version.
I sent the program to you and @maurice by email.
I ask you to solve the problem.