Tstat10 Bricked

Hi, I have a Tstat10 that is ‘‘Bricked’’ as you call it. I have tryed to use the IPS tool to download a new firmware in it, but either it says the device is offline no matter how it is connected or it shows me this

Looking at the messages there, PID10 is an old product model out of production now. I think if you were to update your T3000 front end that would fix this message at least. You can do that from T3000 -> help -> check for updates -> update T3000.

Then looking at the firmware version 50.3, that is also an old version. We’re at 53.8 now. If you have another device you could update that one which would result in saving a copy on your hard disk. If you don’t have another device you can manually download the file form the ftp folder. I see that 53.8 is there:
https://temcocontrols.com/ftp/firmware/Tstat10/.

image

Bricked Tstat10 too.
So I did firmware update, to 53.9, it said successful, then rebooted the stat, now it just flashes the display and won’t communicate. I am using USB com tool to flash and communicate.
Any thoughts on recovering it?

There are two questions in this screenshot. First, the file name does not match the product. Are you sure that you want to update Tstat10? Our ISPtool prevents incorrect burning of the wrog firmware to a particular device. Secondly, I see you have checked the ‘Flash SubNode’, this is for flashing a device which is on an RS485 subnet connected to one of the T3-XX controllers. If you are programming firmware of a controller over IP such as Ethernet or Wifi then you select the "IP and Port’ option further above.

From what you are describing, we think your product is one of a small number of early version samples that went out which had a ‘256k bootloader’. Once you update your T3000 application and along with that you will get a new firmware updater ISPTool, this new ISPTool will automatically update the device to support the more recent ‘512k’ bootloader in production now.

It was a 50. Something. So I discovered some things and recovered it.
53.9 changed the baud rate from 76800 to 57600.
It also had some weird database things. I reflashed with 53.6 and it works fine. The baud rate also went back to 76800.
I didn’t change them…
I suspect there are some oddities with 53.9

Just my opinion

Typos happen…

My problem is very similar to jdewar99’s. When I first received my Tstat10, I tried to flash a more recent update into it and it wrote succesful on the IPStool. Then the Tstat10 flashed on power up and then nothing. Black screen. So I tried reflashing it but i never could communicate with it. I will try with an older firmware and differents baud rates. I will get back to you soon.

Cordialy

According to the description above, for both of you actually, we think you are working with some of the very early Tstat10 units that were shipped with a bootloader using the early version small code space, there were only a handful of such devices and we have increased the code space on the more recent shipments. You should update T3000 itself and then update the device firmware to Rev 53.9. All the issues described above are fixed.

I have just gone through an upgrade where the bootloader got replaced, the firmware uploaded and the screen went black. Another attempt upgraded the bootloader again, but the firmware upload failed - the device timed out. Now resetting power results in a white screen, no ISP mode.

If the unit powers up with none of the ‘two blips’ flashing of the backlight for the first few seconds after power up then there’s a problem with the bootloader. The unit can be recovered by starting with a fresh bootloader but it requires an ‘ST Link’ programming tool, we can get one to you if that’s the case. Send an email and we’ll coordinate that.

If you’re updating over Wifi then please try with the RS485 connection.

Yes, I’m willing to try to recover the unit. I have been using RS485, but the last upgrade ended up with the display on solid with no blips.

Please send it to:

1 Like

Hello, I seem to be having this problem as well. I am programming with an ST-Link programmer over USB and seem to have bricked the device. I’ve tried reprogramming the bootloader (maybe I’m using the wrong file?) to no avail as well.
I’m also using the rev60.4.hex firmware.
Are there any steps I am missing?
I am using the STM32CubeProgrammer software with the ST-Link dongle.
Thanks!