Tstat8 bricked

I’m updating my Tstat8 to 9.4 firmware. Nine of ten thermostats upgraded correctly while one go stuck part way during the update. Now the thermostat is flashing (ON short, OFF short, ON short, OFF long ) and nothing is written on the screen while usually “Updating…” is printed) and doesn’t accept firmware upgrade anymore. I’ve tried also disconnecting it from T3 Controller and connecting it directly to USB RS485 key unsuccessfully: ISP tool reports “device is offline, please check the connection”. Connection is ok because I’ve tested several devices with diffenrt modbus ports.
Any idea to restore the thermostat in order to flash the firmware?


The device has been ‘bricked’ as we say in the electronics hardware business. Fortunately its easy to recover the Tstat8. There is a bootloader which is active in the first few seconds after power on, during this time the stat is looking for a connection to the ISPTool for new firmware. You have about ten seconds to try the update after power up.
In my example here I am recovering a device on the subnet of a T3 controller which is also possible. If you’re having troubles over Ethernet you can do a direct RS485 connection as you tried, but this time try again loading firmware again right after power on.

If you’re not sure of the ID you can try at the global broadcast ID of 255 but be sure to do this with only one device connected.

1 Like

I have same trouble as ddozza, but the Tstat8 serial 122491 accept to install the firmware Tsta8_Rev106.hex every time I try, but show “Programming succesful”, and the Tstat8 flashing LCD 8 times every 15 seconds. Never finish the flashing cycle.

Here I attach the picture of the ISP as Programming Successful

The latest ISP Tool version number is 6.3.7, please try using T3000-help-check for update software after updating firmware.The latest Tstat8 firmware version is Tsta8_Rev112.hex. Make sure the baud rate is correct.I have tested many versions, and it is difficult to reproduce the problem you described. If there is still a problem, could you please let me help you solve the problem remotely?

Hi the trouble was with firmware 10.6 (latest found on Temco website yesterday)
Also I tried 10.1, but have same issue.
I solved using 9.8, but can´t use Schedules.
Today Temco released 11.2, so Il will try with it, to check if Schedules are available as included on lastest Tstat8 manual:

I already tested 1.12, but have same trouble.
The Tstats8 I have only accept V9.8 and below.

1 Like