Troubleshooting Modbus subnet communications with the T3-Nano

I have a very basic configuration with a Nano and a PT12 and AQ sensor.

Connecting the PT12 was easy, getting working very fast as expansion io
The problem came when I added the AQ sensor.
I made many trial yesterday but could never get both slave working together for more than 5 min.
One strange thing is that some parameters are automatically changing in the t3000 database like baud rate…
At the startup, my configuration was 19200 baud for subnet and I saw that the AQ slave was working at 115200 …
What is the procedure to define and fix the baudrate for all sensors in a subnet?
It looks like the AQ would be forcing the master to work with 115200 when the PT12 only work when baud rate is 19200.

I also try to put a Metz connect output module on the same subnet or on another one but the result is the same.

This output module configuration is easier because there is a clear procedure using the included rotary switch to define the baud rate in a programming mode or define the network I’d in normal mode.
Nothing like this for the temco product
Every is supposed to work automatically but when it is not working? How to solve?

I don’t understand how a slave can be connected after discovering and get disconnected later without any modification on the hardware or the parameter .
The baudrate changing is my only track for now.

Thanks for your help

Thanks for your support

I will work on this with you tomorrow. Would you mind to sketch up a network diagram, describe the software you’re using and if possible any sort of network log file (wireshark is your friend). We will set up a test here to duplicate and understand the issues.

Thanks @maurice,
I will draw the sketch this evening.
A next thing I could try would be to use bacnet to connect both PT12 and AQ on the main subnet while using modbus only the Metz triac output module.
The last one would be to connect the PT12 using IP but I’m not sure if it can be seen as expansion of Nano in this case.

Here is my sketch

Originally I tried to put everything on the main RS485 subnet
But when I suspected some trouble with the baudrate, I moved the external module to the sub RS485 subnet.
At one moment, every thing was at 115000 bds but PT12 was Disconnected
After I changed back to 19200 bds, PT12 work again but AQ is disconnected.
The question is thus how to change the baudrate on AQ or PT12 to make it work at the desired baud rate.
The change of baud rate is possible from the master communication property display
Are there some condition to check before to change the baudrate?

If it is a software change , do I need a power off/ on after ?
How is it possible to check the real baudrate on a rs485 when the master says 19200 and one slave indicate a higher baudrate ?

I tried bacnet without more success
Now discovering is really going very slow on subnet,
Scan ID from 5 to 5 , then 6 to 6… Why?
Finally I tried a “clear subnet database’ but no more success with scanning
So I connected only PT12 on IP and saw it was still selected in bacnet… access on IP was ok
Then I selected it back to modbus
On Nano , the autoMapping was copying all inputs 2 times ( probably because seeing it on two network … but it is stupid
Then I disconnected the ip and three was updated automatically
Then I connected again AQ sensor and it appeared also automatically in the tree but named T3_PT12 also .
I renamed it to AQ
So now it is ok…
I think subnet database was corrupted somehow…

Baud Rate: All devices must share the same baud rate and protocol.
You can adjust the settings in the communications dialog for the product, if you have trouble finding it you can have a quick look through the product documentation and will find it. If you’re still having troubles I will take some screen shots for you. Note that changing baud rates, especially with bacnet protocol, you will need to connect to one device at a time. Some devices have a keypad and you can change the baud rate from the keypad directly. 115k baud rate works for most products but if you’re having problems you can try with a lower baud rate.

Bacnet discovery generally goes quite fast because the T3 controller will buffer and reply to the who-is commands on behalf of the subnet devices. If its going slow there could be other problems at play.

If you’re scanning with the magnifying glass symbol that can get slow becuase T3000 tries with all baud rates to each modbus ID, it takes a long time but fortunately you dont have to do this very often. You can interrupt the scan at any time, eventually T3000 will discover the subnet devices in the background and add them to the tree.

Thanks Maurice
I think my mistake came from changing the baudrate with more than one slave connected
I changed it only because I saw probably a wrong baudrate indication some where
Now the priority is to be able to read and write the AQ values

Yesterday evening I could get PT12 and AQ I’m the tree in modbus at 19200 bds without Red Cross
In this configuration I could have the PT12 working as expansion of nano.
And I could read register of AQ using the modbus poll
But any trial to read them with a small control basic program to save them In var never succeed …
Example AC_H = 1.10MB_REG137 never works
So I tried your advice to work with bacnet at 115k
But then I lost everything …
Nano was not able to detect PT12 anymore…
So before to change to bacnet I wanted to have a faster speed…
But after changing the speed on slave first and then on master the connection was lost
Even discovery scan cannot find PT12…
The suddenly PT12 appear again in the three but the modbus master speed was 115k and the slave speed only 19200… how is it possible?
I am really disappointed …
I agree to use bacnet for PT12 and AQ sensor but I need a clear step by step procedure to configure them and be sure to avoid any mistake that was not foreseen .
My feeling now is that the software allows too much manipulations that are dangerous and can put the database in a wrong situation…
In this procedure all parameter change, disconnect slave , power on/off must be clearly written

try at a slower baud rate and report back please. depending on the cable, program size and polling environment the t3nano may operate better at a slower baud rate.

Maurice Duteau

I spent 3 hours yesterday trying to get the AQ connected on bacnet but I had to cancel… sometimes even the NANO is considered as disconnected by the T3000 software. I saw some red message saying that t3000 failed to get email config of Nano…
There is nothing special there…
Nano is connected to the computer by tcp/ip.
How is is possible?
Some times the AQ sensor appeared in the tree but was not really available…
I will try to find another Ethernet switch, wondering if my switch could be the cause of the trouble.
What is the procedure to force the AQ sensor to its factory settings?

My experience show that this kind of programmable device state depends not only on the parameter the software shows but also on the sequence of test done before …
I would like to restart from scratch.

So if the Nano did not add the data read by program, I have to understand first what is wrong there…

If a program line is not working, where can I find the error message that will give me the reason of the trouble and help me to debug.

I searched on ‘debug’ in the software manual but could not find anything about the >database >>logDetail window that could be interesting for diagnosis

Regarding the control basic programs, what if one program fails to execute its commands, are other programs affected. I see this as independant tasks
In my actual configuration
PRG1 is making some filtering on measurement from PT12
PRG2 read write some coils to the external Triac module
PRG3 read data from AQ sensor
Could it be that t3000 is disturbed if this PRG1 is running when PT12 is disconnected?
Could it be that PRG3 never work because PRG2 has some trouble?
Can I disable program without deleting them?

Thanks for any help on this subject

Debugging Network traffic: For now all we have is the network points grid that I believe I showed you… must be in another thread so here it is again. This screen shows you the status of all the data coming in over the network.

For debugging deeper, the developers here use the Modbus and Bacnet tools that are included in the T3000 menu system. There are some log debugging windows, I will ask the team to add them to the menu system in the next release so you can see them too.

Wireshark can be used for Ethernet communications and also I did a writeup on using Wireshark for debugging MSTP traffic.

Programming: The programs run sequentially, you can turn them on or off manually, there’s no way, currently at least, to turn them on and off in a program. Output states are buffered till the end of the program, after the last line is executed the state is written out to the actual hardware, be aware of this when programming not to loop a program back on itself creating an infinite loop. And another golden rule is to program a particular output only in one program otherwise you will get separate programs competing for the outputs.


Thanks Maurice for this feedback

The log windows are already available but I just need some software manual to know how I can use them.

Yesterday I tried a direct connection from my computer to the Nano using an usb to Ethernet converter with another Ethernet cable without more success…
I also replace all RS485 cable by shielded cable but I didn’t notice any improvement.

the Nano was detected and PT12 too but as soon I begin to work with the AQ, I got in trouble even loosing the connection to Nano again…
I wanted to install a new T3000 software in another directory but it is not possible on the same computer .

T3000 seems working very well on my professional laptop until it is is killed by Mc Afee defender…( every 10 s when access into to network of database ? )

Why does T3000 need admin right confirmation at each starting of the software? This is the only software I ever see that needs such thing.

So now I need to buy a new computer running T3000 and codesys faster but without Mc Afee protection blocking my work…

I found a button to force factory setting in setup page for nano but not sure it worked because I lost the connection to Nano and could never recover it…

What about the PT12 and AQ reset to factory settings, I cannot imagine that there would be no way to do it…

I want to restart from scratch and from a clean T3000 database…

Are there anyway to save the T3000 database when communication are working with some slave to have a king of restart point when thing goes wrong and even connection to Nano is lost…?

this project is quite complex for your first tests of our system. try without the codesys system if you could to get started. once you have that working I will guarantee that we can tie in codesys in due course.

Maurice Duteau

I don’t think that the problem come from future use of codesys… I would say that II should save me some headache…because there you can really follow the execution of the code step by step and get error message when you type something wrong.
In control basic, you just get a syntax error on line XX… you don’t know why? And some time it takes time for syntax error to just refresh the status…
This is why I want to use control basic for the minimum task like filtering, converting PWM setpoint into time triggered output…On triac output … and give some basic room measurement and local setpoint management with AQ…
All the more clever tasks will be implemented later with codesys…
But even the very simple job like connecting 3 modbus slave on a RS485 modbus made me spend more than 30 hours last week…

This why I am disappointed…
But from my experience, when thing are going completely wrong and nobody understand how it is possible, just make a reboot can help… to restart from a clean situation…
This is what I want to do know By installing T3000 on a new faster computer, and configure all slave from their factory setting.

Persevere, we will get you there. more tomorrow when I get to my PC

Maurice Duteau

The problems for the nano loosing his connection is very basic in fact .
He is just not able to keep his IP address after a power off…
And sometimes loosing it during power on…
What is the procedure to recover it to it’s factory default IP?
Now I am using a separate network on the range 192.168.0.x so it should be easier but even in this case some times nano does not answer to any ping command.

I checked with arp -a windows script command
The Nano was not anymore in the list.
5 hour later… without touching or doing anything, Nano is back with his address… so what can I do to avoid this ? How can I identify the cause of Nano loosing its connection on tcp IP?
Is there any diagnostic buffer that I could read, copy or transfer to temco for detail analysis by your team?
Wireshark could be a diagnosis solution as you wrote.
Please indicate how to configure it to get interesting data for this investigation.
I am not familiar with this software.

Sounds like the device was not getting an IP address from your DHCP server, could you show me this screen at Tab1 and try with static IP if problems persist. For what its worth, IP addressing is tested, tried and working well for many years.

Tab2: If you have both Bacnet and Modbus subnets operating at the same time in this system you will need to update to the latest firmware to support that.