BacNet MS/TP and ModBus subnet communications

I recently ordered 4 Tstat8’s. I am testing out getting just one to work before I wire up the others. Rather than use the T3000 software, I am using a JACE 8000 with Niagara workbench 4.8. I have tried adding my Tstat8 via BacNet over MSTP and Modbus. I have tried multiple baud rates for Modbus and BacNet MSTP and have not found the device after a search through either protocols.

I have configured the limited settings offered from pressing the arrow < > keys on the thermostat. I have set my Protocol, Baudrate and Modbus address.

It looks like BacNet MSTP is just flat out not working which is very disappointing as I ordered these specifically because the documentation for the tstat8 said it could do BacNet MSTP. I have tried to discover device multiple times to no avail. Though when I leave the JACE on BacNet and change the tstat8 to modbus, it gives me a warning on the tstat8 screen that BacNet MSTP protocol has been detected.

I decided to give Modbus a shot. Though I was not able to discover the device with that either.

I feel like I am missing some important information about the tstat8 to configure Niagara workbench for Modbus.

Modbus Port configuration in Niagara Workbench 4.8 asks for, with these as the options:
Port Name: COM2 for this project. (Got this figured no problem)
Baud Rate: Baud19200 (Was easy enough to set this from the Tstat8 menu)
Data Bits: Data Bits8, Data Bits7, Data Bits6, Data Bits5 (Which to select out of this?)
Stop Bits: Stop Bits1, Stop Bits2 (Which to select out of this?)
Parity: Even, Odd, None, Mark, Space (Which to select out of this?)

I have read all documentation for the Tstat8. Though I could have missed something.

Can you help me get my Tstat8 working with my JACE. I have a few days to spend on this before I have to give up and attempt a return of the product for not working.

Rest assured we’ll get you up & running in the Jace/Niagara environment, we have been working with integrator for years using Bacnet in this environment.

Could you give it a go with connecting using our T3000 software first and check the communications settings from there. Do this without the Jace involved to get started. Once you’re connected also update the firmware using T3000 -> help -> check for updates. Once you have the system working in that environment you can bring on the Jace to see the Bacnet objects.

The default settings for parity and stop bits are N81 and you shouldn’t change that unless you have a good reason. Where we see that is with some odds & ends power meters & devices that don’t have the ability to be set to the standard N81 setting.

Thank you for getting back to me Maurice. I have ordered an RS485 to USB converter. It should be here by Friday, April 24th, 2020. Once it arrives, I will attempt to configure the Tstat8 for BacNet using Modbus over the USB converter with the T3000 software.

First I will update the firm ware. Then will configure for BacNet. I will use the pdf guide posted on the Tstat8 webpage.

I will post here in this thread if I have any questions.

My RS485 to USB convertor has arrived. I have tried all 4 devices with Modbus on COM3 usb serial at baudrate 19200. None of the devices showed up. I made sure to set COM3 to 19200 baudrate in Windows 10 as well through the device manager.

I only hook up one device at a time while experimenting like this. I left one back plate wired in and switched the Tstats between the back plate.

I have discovered 1 out of the 4 thermostats has a screen that will not turn on. The other 3 will boot to show their screen. I made sure to double check their protocol settings. I was still not able to find any of them with the T3000 software.

It seems to me the only issue could be wiring. As such I have rewired this set up with a different back plate, tried everything again to no avail.

Please let me know if there is anything additional that I can do.

Thanks for the good troubleshooting there Mark. There’s one possibility that has caught a few folks up in the past, the wire can be in fact inserted on top of the screw cage.Tightening the screw feels like you’re clamping the wire but in fact the wire is hanging in a gap below the screw cage. I tried to show it at Tab1 there but its not easy to see.
Another option is to connect directly with the pluggable terminals you see in the trade, 0.2inch spacing. Hook those in directly as shown at Tab2.

There is a phono jack port on the bottom of the Tstat10 that is wired in parallel with the main RS485 bus. We sell a low cost RS485/USB converter with the matching phono jack on our web site.

Check in the menu system of the device itself, you can adjust the baud rate and protocol using the keypad. To get into the keypad you press teh left and rightmost buttons, both at the same time, for about five seconds and the device will switch into menu mode, from there you can scroll around till you see the settings. This is just for a sanity check, the T3000 is pretty reliable at discovering the devices using the magnifying glass icon search.

You can try setting the device to Bacnet protocol and it will start passing the token, the RXD led of your converter should start blinking. When you scan with T3000 you should of course see some LED activity on the TX led.

Here’s the scan icon in action from T3000 in case you werent aware, you do need to manually select that scan in order to do a deep discovery of devices at different baud rates and protocols.

Finally, you mentioned one device has nothing showing on the screen. If the LCD somehow became disconected during shipping you should still be able to connect to it. Once we sort out this connection issue we can decide on next steps for this one. We may have to swap that unit with you.

I have tried the additional options that you have posted. I was not able to communicate with a single thermostat.

I tried switching the Tstat8’s to BacNet protocol and did not see any blinking of the Rx light. I tested a thermostat of another brand that we had laying around. It was able to communicate and can be seen passing its token by showing a blinking Rx light.

I am sad to say this, as I really needed to have these thermostats to work as they have CO2 sensors and I am using them in a horticultural application in the lab, but I think I am going to have to return the thermostats. I don’t have enough time to continue troubleshooting this issue, especially given that I can get a thermostat of another brand to work no problem (it does not do CO2 though). I feel like I just got a bad batch for whatever reason. Perhaps the COVID lock down had some effect on the manufacturing plant in china from which I received the thermostats.

Let me know if you have any hidden solutions up your sleeve or if you can instruct me on how Temco would like to proceed next given this information.

The only thing I can suggest here is to try with another RS485 converter, we have some stock in the US and they’re only $12. This way you’ll be able to connect directly to the phono jack at the bottom of the stat. There’s also a screw terminal connector for a wired connection to the backplate.

@maurice @Fance @chelsea Good I have recently bought some Tstat10 and one of them is Wifi and connect them by Rs485 to a T3Nano but I can not find it already change Protocol to bacnet and the speed equal to the Rs485 Master input of the T3 Nano as I can manage to connect Since I have not Converted from Usb to Rs485

I understand that you are working on connecting to a T3-Nano over Ethernet and from there you have a Tstat10 wired to the RS485 subnet using Bacnet MSTP protocol. Here is a screen shot of a similar connection in the office here. Make sure the device and the T3-Nano are both set to use MSTP at the same baud rate.

When communications are set up correctly you’ll see activity on the T3-Nano RS485 subnet leds and also on the Tstat10 there are two arrows on the LCD display showing MSTP activity. There’s also the network health dialog at Tab2 up above which will help with debugging.

Finally, make sure each device on your subnet has a unique Bacnet MAC ID or Modbus network ID as its called. The T3-Nano has an ID here and so does each device on the subnet.


Good I have not managed to connect any of the Two Thermostats Configure them in 19200, Bacnet and connect to the SubRs485 port of the t3nano and I cannot


I managed to connect through ModbusMaster, you will know why I cannot by bacnet?

I will need more info in order to help you out with that Luis. Modbus is usually quite straightforward, all the same rules about communications with Bacnet apply to Modbus. You need to make sure all devices are set to Modbus, all devices have a unique network ID and are set to the same baud rate and you’re good to go.


Does anyone know if the main sub bacnet connection will display the points on a touchplate lighting control panel?
Touchplate is bacnet/mstp.

You can read & write Bacnet objects over all the ports in all directions so if your touch panel can work with those you should be in good shape. A short program program running on the T3 programmable controller can manage the traffic, etc. Search this forum for ‘network programming’ for examples on how to do this.