Modbus poll vs temco modbus poll for external devices

Hello Maurice and TemcoTeam,

My goal is to add [non temco] modbus devices within the T3-XX network
Prior to that, I want to be sure that my modbus devices are working as expected.

I hooked my modbus unit with a temco usb-rs485 cable and tested through my modbus poll: ID, port, speed, etc. And the result is ok, I can harvest data in a regular manner.

Without touching anything (same computer, modbus cable and settings), I lauched the temco modbus poll program (within T3000 software) and tested my T3 (TCP): OK
However, when I try to change the TCP connection for the usb-rs485, I have100% connection errors (with the correct parameters).
Because of my previous tests, I know the connection is OK, but for unknown reasons, the T3000 Modbus poll failed on serial communication (I didn’t try to reach my device through the main/sub rs485 because of this serial falure).

Any 2021 idea ?

peacefair DC-017 modbus poll L635 OK

Update:

I tested the very same config with an old Temco unit (T3-8I13O) and I have the same problem through serial: The regular modbus poll program works but the Temco modbus program won’t.

T3-8I13O modbus poll L635 OK

Sorry to answer a question with another question, but could you give me a sketch of what’s going on in the above setup. We think you are trying to poll to RS485 subnet devices from other manufacturers and using our T3-BB or similar as a general purpose IP to RS485 gateway.

If the assumption is correct then possibly the packets you are sending are not fully supported by our routing functions, our devices support routing for some modbus functions but not all of them. We mainly support the Modbus commands such as read & write registers used by Temco products, that is Modbus functions 03, 06, and 16.

I’m not sure this will help your application but you can do some reading and writing to third party devices with a program running in the T3 controller. See the section titled ‘Network programming’ in the link below for more info on how to do this:

Yes, but.

Yes at first. The clear idea was to poll within T3 modbus adresses from third party modbus devices, taking advantage of the rs-485 main/sub network. Regarding your reply, I need to go further.

But. Because the result was not as expected, I hooked an old T3-8I13O and tried to add it automatically (scan) to see if the network scan worked.
The automatic scan was a failure (not detected, serial or main/sub). But was succesful if I added it manualy (add serial modbus device), including the integrated modbus poll from T3000 (latest version).

I tried then to follow the same pattern (add manual serial modbus device with its ID): failure

Maybe the T3-8I13O is too old to be recognized by the automatic scan and the third party modbus device is totally unable to be added into the T3 network, because of your answer…

Update:

I wanted to be sure about my wirings and settings: I hooked a T8 to a T3 unit through my modbus sub and it was recognized right away with the automatic scan. So, it confirmed that the “culprit” is the modbus connection between T3 units and third party modbus devices :frowning:

Still having a tough time to envision what you are up to there Mike. If you are having trouble discovering devices on subnets you can connect directly over Ethernet and do a firmware update, do that from T3000 → help → check for updates. You should update both the T3000 front end and the device firmware while you are at it.

Also you can make use of the T3000 → tools → modbus tool to see the live Modbus registers of Temco devices at least (not the 3rd party devices though).

~WRD255.jpg

image001.jpg

image007.jpg

my post was about this, sadly. No probs to recognize temco devices (at least new ones like T8). I hoped to integrate 3rd party devices through T3 unit sub-rs485. If I can’t see them or access them, I need to change my way to integrate them into my modbus network.

Thank you anyway for your help.

A small hand sketch will go a long way to helping me help you. See what you can come up with please.

As always, if you’re having troubles connecting things make use of the firmware update system,

T3000 → help → check for updates → update T3000

Update firmware

Show us a few screen shots and I can make better suggestions.

image001.jpg

image007.jpg

OK.
Updated T3000 to the latest and T3-LB to the latest (54.4 / 55)

This T3-LB unit is for test only. Just a 10K temp sensor hooked and a time variable
Hooked a Peacefair Modbus Voltmeter (works in standalone mode with provided prgm and through my own modbus poll prgm and through serial-rs485 with node-red) into RS485 sub (2 stop bit, quite unusual).

Tried to access T3000 modbus poll (worked before -except the DST- the firmware update - was 51.0): received a “please config the way of your connection” message instead.

T3-LB modbus poll config question

Tried to modify data (same as a production T3-TB btw who can access built-in modbus poll) and obtained that message:

Unable to change data except baud rate (I use 9600 with 3rd party modbus devices). Stuck there and still unable to access modbus poll for T3-LB

T3-TB doesn’t ask for this and the modbus poll access is allowed

That’s it !

OK, our team will study this and report back shortly.

Maybe this could help:

I tested this problem on two W7 computers (with latest T3000 software): same error

I downloaded T3000 software from your site (may 29 2020 .16) and ran it directly (no update) on a W10 computer (that had never seen T3000 software): NO error.

I updated (1.1.9) this T3000 on the same W10 computer and ran T3000 again (dec 24 2020 .14): same error

So it seems to me that this error is not related to the OS but seems to be related to the latest T3000 firmware.

  • I used software to simulate third-party devices
    N-8-2 and Baudrate is19200 , I connect this devices to T3BB’s RS485 sub port .

I set Both T3BB’s RS485 Subport and Main port to Modbus Master . The result’s is Got timeout error .

If Only set the RS485 subport to Modbus

Master , to read the third-part device data it is OK. ( * Modbus data is forwarded to third-party devices through the T3BB network)

So, if you want to use third-party devices (via modbus) and connect to Temco devices, you just have to configure one of the RS485 ports and just line up Unused ports (because third-party devices don’t complete part of the command line that supports Temco).

Thanks Fance, I did it and I hope that will solve the problem.

But I’m still unable to access modbus poll with the latest T3000 software (previous message).
2 choices for me: wait for a T3000 update or reinstall the orginal T3000 and use it without an update.

I tried.
If I use the latest T3000 software update, the time variable is ok (DST) but if I use the previous T3000 version, the modbus access is OK, but not the time variable…

About the 3rd party access, with the “old” version of T3000, I can access modbus poll but the result is not OK. The network health is +/- ok (timeout), some RX
But when I harvest the modbus device, I can’t poll data (write error) even I respect the parameters that works with other software.

settings that is OK with rs232-rs485 and my modbus poll:

peacefair DC-017 modbus poll L635 OK

I have just uploaded the latest T3000 software and fixed a possible exception message “Please config the way of your connection!” when using the T3000 Modbus Poll.

I have also repeatedly verified just now that T3-BB TB-LB is able to access a third-party device normally by connecting it to a third-party device in the RS485-Sub Port and using the connection shown below. ()

The only thing to note is that RS485-MAIN and RS485-SUB cannot be set to “Modbus Master” at the same time when connecting to third party devices.The implication is that one of them must be set to Unused.

If both ports are set to “Modbus Master”, the T3 Controller will communicate in accordance with the configuration of RS485-Main port, and if you happen to connect the third party device to the SUB port, the communication will not be normal.

Please check again if the configuration information is wrong.

Updated T3000: OK, works as expected.
Connected my modbus device as requested and launched modbus poll: OK
tested the connection: KO, write error, whatever settings

Please Update T3000 again . Version : Jan 6 2021 . 14
Fixed a bug where the T3000 Modbus Poll established a TCP connection with the server and the connection was disconnected by the server, causing the communication to be unable to continue.

Bug phenomenon: Write Error after communication for some time.

already updated with the latest version (6 jan) on my previous message and tests

Yes ,Today I release two of these versions.
Version : Jan 6 2021 . 13
Version : Jan 6 2021 . 14
If still have problem ,please let me know.
Thanks!

Updated with the latest T3000 version (.14): OK
tried to poll modbus unit: failed
will install another 3rd party modbus device instead of my unit to see if the problem is consistent
thank you for your time

I really can’t find the reason why you;re still experiencing problems.The following screen shot shows my connection as you describe your situation and here result here is completely fine.
I also use the command “04 Read Input Registers(3x)” , all works as expected.

We have both burned up a lot of time here, it would be best for us to do some remote assistance using Teamviewer or https://www.remoteutilities.com.
Please email and arrange a time to connect with you.

I really appreciate the help here.
But prior to this, I’ll hook another 3rd party modbus device that works differently (rs232-485, node-red, plc) and test the T3-LB behavior again with this.

If I have the same kind of problem with another device, I’ll let you remote control a computer with T3000 access.

1 Like