Trouble installing and running T3000

I always get an “attempted an unsupported operation” error on startup. On the rare occasion that it actually starts, I see no way to get bacnet IP to work in any manner. What am I missing?

 

Got the software to load and it comes up on my PC just fine. I think there are two key points here:

  1. load the software from the 67MB .exe file. I developed a piece of software with Visual Studio once and the .exe version for loading more reliable.

  2. It appears that the software is not happy if it doesn’t see a T3000 on your PC’s network and will an “unsupported function” error if you bring up the software without your t3000 controller connected and running.

The link for the T3000 application is on the product page as shown below, copied here for reference:

https://www.temcocontrols.com/ftp/software/09T3000Software.zip

I will make sure the github msi file is working as well, just got word from my crew and he has tested and zipped it all up in the release folder.

If you’re doing any development work with the github repo I’ll be glad to help get you set up, just send and email to any of the listed contacts and it’ll get to me.

Maurice

I am having similar problems. I downloaded the .msi from SourceForge because I could not find it on the TemcoControls web site. I tried to install that on 2 different 64 bit PCs; my desktop and my laptop. On the desktop I keep getting the “Attempted an unsupported operation” error and on my laptop I get “code execution can not proceed because VCRUNTIME140.dll was not found”.

So I am trying to be self-supporting and came to this forum. You have recommended that the latest build of the T3000 software is here: “https://temcocontrols.com/ftp/software/T3000.zip” I get a page not found when I tried that. Where do I go from here?? Does this have to run on a 32bit PC? Do you have to have .Net 3.0 installed first? Are temcocontrols and bravocontrols the same company?

 

Ted Northrup, Queens Oaks

Sorry to hear you’re having such troubles, am standing by to help. There can be a number of things going on so let’s start with updating to the latest (again) and updating the firmware of your device as well.

Maurice

**********Updating the T3000 Front end and Device Firmware ******************
To update the T3000 front end, if it has only been a short time since you updated you can update T3000 by running T3000 and selecting help -> check for updates -> Update T3000, as shown at tab 3 in the figure below.

If it has been a long time since you updated and are still seeing unstable behavior you can do a clean install by deleting the earlier installation folder which is shown at tab 5 and re-installing. The programming and other project files for the various projects you have worked on will be stored in the ‘Database’ folder so be sure not to delete this folder if there’s important work there, in your case since you’re just getting started it would be best to completely delete all files and do a clean install.

The zip file for the T3000 application is here: https://temcocontrols.com/ftp/software/09T3000Software.zip

Once you have updated T3000 you can connect to the controller and update the firmware. From T3000 select help -> check for updates and then ‘Download Firmware & update showing at tab 4 above.

If you have difficulties downloading the firmware you can try again later or do a direct download from this folder: https://temcocontrols.com/ftp/firmware/

If you get stuck half way through a firmware update you can revive a bricked unit by re-flashing in the first few seconds after a power cycle, the heartbeat LED will be repeatedly flashing with two blips in this period as opposed to the usual one blip for normal operation. Use the ‘Load firmware for a single device’ from the T3000 -> Tools menu, this is faster because it gets the firmware from your local disk rather than the ‘Help -> check for updates’ method which downloads the latest file from the net.

 

 

Do you ever actually try your own software? I loaded the “new” version and I immediately get the “attempted an unsupported operation”.

Do have a go with the latest version David, its updated nearly every week. Tested on all Windows platforms before release. https://temcocontrols.com/ftp/software/T3000.zip

 

We tried installing T3000 on a virtual machine running Windows 2008 R2. The error we got was “Update database! Please restart again.” Does anybody have any tips to get it running?

Sorry, havent got any experience using a VM, the software is tied fairly low level to the hardware for communications, especially the COM ports and Bacnet MSTP, so I wouldn’t be surprised if the SQL error is the only error you’d be up against. Let me know which VM you’re using and we can check this out though.

Update1: Our developer here suggests installing .net 4.0 which you can download here.
https://www.microsoft.com/en-US/download/details.aspx?id=17718

Update2: Not sure if this is relevant but another client had trouble with Win7 and was able to get things working by setting the compatibility mode to ‘winnt sp5’