Installing T3000

I always get an “attempted an unsupported operation” error on startup. On the rare occasion that it actually starts, I see no way to get bacnet IP to work in any manner. What am I missing?


Do have a go with the latest version David, its updated nearly every week. Tested on all Windows platforms before release.


Do you ever actually try your own software? I loaded the “new” version and I immediately get the “attempted an unsupported operation”.

Sorry to hear you’re having such troubles, am standing by to help. There can be a number of things going on so let’s start with updating to the latest (again) and updating the firmware of your device as well.


**********Updating the T3000 Front end and Device Firmware ******************
To update the T3000 front end, if it has only been a short time since you updated you can update T3000 by running T3000 and selecting help -> check for updates -> Update T3000, as shown at tab 3 in the figure below.

If it has been a long time since you updated and are still seeing unstable behavior you can do a clean install by deleting the earlier installation folder which is shown at tab 5 and re-installing. The programming and other project files for the various projects you have worked on will be stored in the ‘Database’ folder so be sure not to delete this folder if there’s important work there, in your case since you’re just getting started it would be best to completely delete all files and do a clean install.

The zip file for the T3000 application is here:

Once you have updated T3000 you can connect to the controller and update the firmware. From T3000 select help -> check for updates and then ‘Download Firmware & update showing at tab 4 above.

If you have difficulties downloading the firmware you can try again later or do a direct download from this folder:

If you get stuck half way through a firmware update you can revive a bricked unit by re-flashing in the first few seconds after a power cycle, the heartbeat LED will be repeatedly flashing with two blips in this period as opposed to the usual one blip for normal operation. Use the ‘Load firmware for a single device’ from the T3000 -> Tools menu, this is faster because it gets the firmware from your local disk rather than the ‘Help -> check for updates’ method which downloads the latest file from the net.



I am having similar problems. I downloaded the .msi from SourceForge because I could not find it on the BravoControls web site. I tried to install that on 2 different 64 bit PCs; my desktop and my laptop. On the desktop I keep getting the “Attempted an unsupported operation” error and on my laptop I get “code execution can not proceed because VCRUNTIME140.dll was not found”.

So I am trying to be self-supporting and came to this forum. You have recommended that the latest build of the T3000 software is here: “” I get a page not found when I tried that. Where do I go from here?? Does this have to run on a 32bit PC? Do you have to have .Net 3.0 installed first? Are temcocontrols and bravocontrols the same company?


Ted Northrup, Queens Oaks

The link for the T3000 application is on the product page as shown below, copied here for reference:

I will make sure the github msi file is working as well, just got word from my crew and he has tested and zipped it all up in the release folder.

If you’re doing any development work with the github repo I’ll be glad to help get you set up, just send and email to any of the listed contacts and it’ll get to me.


Got the software to load and it comes up on my PC just fine. I think there are two key points here:

  1. load the software from the 67MB .exe file. I developed a piece of software with Visual Studio once and the .exe version for loading more reliable.

  2. It appears that the software is not happy if it doesn’t see a T3000 on your PC’s network and will an “unsupported function” error if you bring up the software without your t3000 controller connected and running.

I did manage to get it working. But it is unclear how to access inputs and outputs that are from an attached Modbus device. I can scan and see the device and the device registers show up correctly. But how do I reference a value from the device. For example I have a Modbus humidity sensor on the main RS485 bus. A scan show the device and labels it as “Humidity” under the “temcopanel” device on the Local Network. Clicking on the “Humidity” device shows me the 2 INPUTS from the sensor: “Humidity” and “Temperature”. How do I reference those readings ?



This question would be a better fit for the integration forum but I’ll reply here for now.

Devices on the RS485 subnets are handled in two ways, the expansion I/O for example are mapped as external I/O of the T3 controller and can be referred to like internal i/o of the controller itself. 1IN100, 1IN101 and so on. Other devices are easy to integrate but a little programming is required to bring in the data.

In the case of a humidity sensor on the RS485 subnet here is a typical command to read the data from the subnet device into a variable on the local controller.

10 VAR1 = 2.3.REGXXX

Where VAR1 is a local variable on the T3 controller with a network ID on the main (ethernet) ID= 2 and the subnet ID of the humidity sensor on the RS485 network is ID=3.

Reg XXX is the Modbus register holding the humidity reading on the humidity sensor.

If the humidity sensor is set up to use bacnet protocol you’ll use a bacnet command like so:

10 VAR1 = 2.3AIX.

Where VAR1, ‘2’ and ‘3’ are the same as above. AI is a bacnet object keyword for the input X on an external bacnet device.

There has been some discussion here at the office about mapping external sensors the same as external expansion I/O so that no programming is required. You could look forward to that feature in March (2018) or so.

Hello I got a Mc Afee Trojan detection on win10 when running T3000 after installing from zip downloaded from Temco website

Here are the messages

Thanks for your help

I downloaded T3000 from this link as recommended on a previous message of this topic.

There are two links for the same software
What is the difference between both

I used the second one for my install.
The installation process worked properly. The problem came when starting T3000 the first time. I was requested to give again a admin password and then I saw the message from Mc Afee.

they are the same. The tiny URL is useful if you would like to give the link to your clients without revealing the source.

Maurice Duteau

Hello @maurice,
I an reading now the full documentation waiting for an answer regarding running the T3000 on my Laptop.
I found that T3000 default path for application is a Database sub directory of T3000 that is in Program (x86).
This is particularly uncommon .
This directory is protected. All application document should be in app data or in Documents but never in Windows subdirectory…

That could be the reason why Mc Afee sees T3000 as a trojan…
What is the way to configure T3000 to have the database and all application related software in another directory ?

I did not find any possibility to change the configuration in ini files…
So I remove it completely and reinstall it in a temco subdirectory of documents…
Now, I can run the T3000 software.

Hoping the rest will work with this non standard installation.


Hello Fance,

As I wrote yesterday, this is what I did but only possible after uninstall…
To mee it would be better that T3000 software is installed at the default path but all configuration files modified by the program use to be in other directory like app data or document that are in a subdirectory of the user.
Having a windows program installed in a user documents subfolder seems a bit weird to me but it was the only chance for me to have te ability to run it…

It runs quite smoothly on my machine using the defaults. As I understand it you would like to move the application data in this Database folder to a separate location. We can do that feature in a new release soon.

Another option for you would be to install to C:\T3000 rather than C:\Documents\T3000


It is because my only laptop is the one from my company and they apply strict rules to protect as much as possible the computer from attacks…
Basically all directories other than the sub of my user are written protected… I need a special login to make any modification there, what is the case of installing software but should not be the case to just use them…
This is why I finally installed t3000 in my user document directory …

Split installed part and document would be just more standard dir windows application.