Temperature Sensor Network - Modbus Data is not correct

Good afternoon.

I need help with this case.

I have a temperature sensor RS-485 network and with all my sensors connected 1 is giving me a bad measurement.

Separately each sensor works.

Trying to do everything I tested:
1 - Putting another new sensor insted of this one (drop other sensors from measurements)
2 - Putting a terminator resistor (no difference)
3 - Putting another cable (no difference)
4 - Recabling everything (no difference)

It is very likely that there is a serious deviation in the calibration value of your sensor. It is suggested that you connect to this sensor with T3000 and clear the corresponding calibration value. You can refer to the following figure for operation.

If the above methods cannot be solved, could you please tell me which sensor you use and more equipment information, such as software version number and so on?If you still have problems, you can contact our sales and after-sales service, we can provide you with remote assistance.

It looks like you are using a T3-XX device as a router to convert Ethernet traffic to an RS485 subnet with several devices on it. Some data is getting through but one device is showing bad data. It would help to see a wireshark capture of the data, we can often pick up something from that.

You could try reducing the polling speed.

No, i am not using a T3-XX router, i am polling data via Modbus using a RS485 network.

The information displayed is via an ABB PLC, but i could use a modbus RTU sniffer disconnecting the PLC 485 line and pull data from each sensor if you want. The issue is still the same.

I will test the calibration recommendation.

You mean write a 0 to this position that displays 2.0?

The “calibrate” section allows the customer to adjust the value until it matches the actual value tested.For example, if the test value is too large by 10degc, you can change the symbol to “-” and put the value in 10.0, and the sensor will add an offset of 10degc to the actual test value.
Your value 65136 May be a misoperation, resulting in a very large calibration value, which affects the actual value.
You can first try writing the calibration value to 0 .

Hello again.

I could not find this calibration value on the

Currently i have 2 sensors with the same temperature deviated.

And another one I try to update and then the firmware brick the device.

You will need to update your T3000 application and also update the device firmware. You can do both under T3000 → help → check for updates.


5 posts were split to a new topic: Unbricking a Bricked Device

This action will brick the device, i tested in two ones.

The problem of this was that sensor data is deviated, i replaced two sensors and now the network is OK.

Make sure to update T3000 first, then do an update of the device firmware.