Unbricking a Bricked Device

And when a device is bricked when i updated the firmware what i could do?

bricked = try to update, erased the device and do not pass the firmware update. Then i try to connect via modbus at 9600-8-n-1 at id 1 and do not responds or use T3000 and it doesnt get found.

There is a thread on this forum for recovering the device. Search for ‘Unbricking’ and it will show up. Basically, you just cycle power and flash with the T3000 → Tools → Update firmware for one device, do that in the first few seconds after power up.


Where i could download all the firmware hex files, i have problems with the flash tool, never finishes updating the microcontroller.

Always give me a Write error (12 = 0)

The best place to find the firmware is right there on your machine, this is the latest and greatest firmware for your device.

You can also find firmware here but its not always the latest version, so go with the one on your PC already if you have something there.

I think the reason you are having difficulty flashing the device is either a poor connection to the device, or your T3000 is out of date. You can update T3000 by navigating to T3000 → help → check for updates → update T3000. You can improve communications by isolating the device, connect to just a single unit for now to keep things simple. Capture some data with wireshark or in the case of RS485 use a serial port data tool and perhaps you can see something from that.

For RS485 connections you can put a (math capable) oscilloscope directly on the lines and plot the A- B channel, look for nice square waves with no ringing or rounded edges.

Hi, still not working.

I am trying to update the device from my USB-RS-485 -----> XDUCER (Temperature)

Still not working

It could be that the device is damaged. I will summarize the unbricking operation here again but we may need to get the unit back here if the RS485 chip is damaged, possibly.

Once again:
You will need a copy of the firmware and the best place to find firmware is here on your hard disk. If you have been working with the firmware update in the past you probably have a copy of the firmware on your hard disk already. You can see this dialog when you navigate to T3000 → help → check for updates → update device firmware.

If you cannot find the firmware locally you can check around here on the website but this is not always the latest and greatest version:

Once you have located the firmware navigate to T3000 → tools → update firmware for a single device. This brings up our ‘ISPTool’ . Here you set up the IP address of the device if you are connected over Ethernet or the Modbus ID if you are connected over RS485. If the device is operating under bacnet that’s OK, the firmware update in the first few seconds after bootup is in Modbus. If you don’t know the ID then you can put 255 here

It is best to do all this with only one device connected in all cases, Ethernet or Modbus.

Cycle power to the device and it will blink the LCD backlight if it has a display, or if there is one, the heartbeat LED. One of these will blink with two short blips repeating every second or so. If you don’t get these two short blips during power up that could mean the device is damaged. Either way you can hit the flash button and give it a try to flash the firmware.

If you cannot revive a device using this tool and this cycle the power & flash method then we will need to get the device sent back here for a checkup.

When updating the firmware on the T3-TB:

  1. Can I update via IP through a managed network switch or is it best to connect directly to the controller?
  2. Which file do I use to flash the controller the .hex or .bin file?
  3. Can the file be in any folder on the PC or does it have to be in a specific file location?

The best way to update firmware is to use t3000, then navigate to help, check for updates, download firmware and update.

Regarding bin versus hex file, looking at the file names here the Asix is an early version of the product and it appears the file name was *.bin. Then the later Arm based CPU came out and the file name switched to *.hex. In fact you don’t need to worry about the file names, t3000 will pull the latest and greatest file from the update folder automatically.