T3 Asix loses it's program

We had three issues in the same job.
The controller lost its program, as if using the “clear device” key

First time:
T3-TB Asix lost its program.
We replaced this device by one i had as spare part.
Second time:
About 20 days later, it occured again with the new device.
We replaced it again with another one (spare part).
Abaut 40 days later and that’s fine.
Third time:
Today it happens again, but this time, a T3-LB lost its program. This device has worked fine for 4 months.

This job has:
1 MT8701IE HMI (BACnet IP) with remote monitoring,
4 T3-TB Asix,
2 T3-LB Asix,
1 T3-BB Asix

Details:
The schedules are transfered from the HMI using data transfer timed based objects to VAR126 or 127. (5 seconds interval pulses). There is 6 schedules events (two on each T3-LB and one on each T3-TB).
All firmware are factory default:
T3-TB Asix - 46.2 (UO-5 ans UO-6 configured and working as AO)
T3-TB Asix - 46.5
T3-LB Asix - 46.5

Hard to say what might be going on Adalberto but we are standing by for support. If you have any failed devices you can send back that will definitely assist our investigation. You can also send on the programs for all the devices and we’ll set up a similar test environment here.

There’s no known issues with the old Asix based system but its worth considering an update to the more recent Arm based CPU system where all the new features & updates are going on. We’ll work out a super deal if you’d like to do a swap.

Maurice

Thanks Maurice for your replay and suggestions.

Until January 9, our client will be closed for New Year celebrations. Only after this date can we replace the device.

The failed device we had (T3-TB) was recovered (downloading firmware 46.2)

We’ll see if we can duplicate the problem with a similar device (TB-LB Asix - not yet installed).

When we replaced T3-TB with the problem, we included units in all VARs used and unused in the program.
Do you think this could bring us this kind of problem?
(Works great when using T3-BB ARM …)

Hard to say at this point what could be causing the problem, we will set up some tests shortly. I remember that your application is very busy with control logic and network points, do consider moving to the Arm version for better performance all around.

Ok, let’s move to the Arm version.
We will also continue our investigation by keeping at least one Asix T3 for testing only.
I believe the problem may be in the network environment because we have other similar installations that are working great.
The original firmware of our controllers are:
Arm 45.5
Asix 46.5
It will be very useful if you can upload these firmware to the ftp folder.
Thank you in advance for your help.

Should be here: https://temcocontrols.com/ftp/firmware/

Yes, I tried to find it out from the link:
https://temcocontrols.com/ftp/firmware/T3_BB_LB_TB/Old_version/
But I didn’t find these old firmware files.
Arm Version - Older firmware file:
mini_arm_rev47.8_10.9.hex
Asix Version - Older firmware file:
mini_asix_rev46.2_12.5.bin (pushed to the ftp folder on December 12, 2019 by Temco_Spring),
Next file: mini_asix_rev47.5_8.2.bin

In general it’ll be best to use the latest firmware, right! You can see the latest revisions as you perform the update.