"SYNC time failed, No Reply from server"

Just hooked up a new T3-TB-11i (first time Temco user) to my home ethernet network hub. First thing I tried to do is “Synchronize with the time server”. Tried time.windows.com which works on my laptop on the same network. Get error “SYNC time failed, No Reply from server”. How to get the controller to Synchronize time with the time server?

Heres a few random tips:

Make sure your device is on the lan with a proper ip address.

Make sure there’s no firewall rules on the router blocking your device.

Try a different time server.

check the traffic using wire shark.

standing by to help.


Hi Maurice,

I turned off Windows Firewall and now I see that under Last Update: it says 5 minutes ago, which is something new. Still, when I click Update it says SYNC time failed, No Reply from server. Also, when I click "Identify Device (Flash LEDs/LCD for five seconds) I don’t get any flashes on the controller. On the Communication Tab. I have Use the following IP address which I can ping from my computer. I installed WireShark but I can’t seem to find an interface with the IP address so I’m not sure how to check the traffic. Sorry for the Nube questions. I figure getting the network communications down first will help me a long way towards getting going with these controller. I’m a mechanical PE with lots of DDC sequence of operations experience trying to get into controls installs.

Firewall: What I was mentioning there is the rules in your router that might be blocking the device itself, not your PC running T3000. Its a longshot but it could be a routing issue in the router itself and may need to be ruled out if all else fails.

The fact you cannot get the LEDs flashing to iidentify the deivce, that could mean you need to update the firmware, do that at T3000 → help → check for updates.

And one thing you should check as well, make sure you are in fact connected to the device. Look at the IP settings at Tab1 and show us what you see there. Check the status line down at the bottom of the screen, you can see the packet counts and communications health at Tab2.

Just checked the time sync on my device here and it is working fine.

I’ll work on the router issue, and let you know what I find.

In the mean time.

I have the latest firmware flashed into the device. mini_arm_rev63.2.hex

See attached for my Communications Tab info. The status bar behavior is strange. On one of my monitors it doesn’t show up at all, either with the T3000 window floating or fully expanded. However, on the lap top screen I am able to get it to show floating below the T3000 main window. However, depending on the size of the subpanel UI it can eclipse it. Anyway, you can see it is communicating with some missing health.

I also confirmed I have the latest version of T3000 installed.

Toggling the the status checkbox under the main View tab resets the status bar to the bottom of the main window on the main laptop screen but it remains hidden no matter what if I move the T3000 window to my extra monitor.

Well I cannot comment on the monitor setup there, dual monitors and resolution settings can be tricky to sort out. T3000 assumes a pretty basic setup.

I can comment though on the time sync issue, I did check it out here and its working well. The next step would be to fire up wireshark and see if you can get any clues from that. Also you could try other time sync servers.

Ok, so with Wireshark, I would try to latch onto the network adapter of the device? And the IP address of the device would be the same as what is displayed on the Communication Tab? So, I should see that IP address as one of the interface adapters that Wireshark finds? The problem is I don’t see that IP address found in Wireshark. So, I’m not sure how to sniff out the packets coming from the device, sorry again for the newbie questions.

I’ll do a few screen shots on how to use wireshark. Give me a moment

Ok, thanks. It says "Identify Device, LED lights and LCD flash within five secondsSuccess! in the status bar (see attached). But, I don’t see anything new flashing on the device. Just heartbeat and ethernet, with power green led always on. Are the input / output LED’s supposed to flash?

Here is how to debug with wireshark. Find the IP address of your device at Tab1. Run wireshark, select which network adapter you will use at Tab3 and set up a filter at Tab4. Finally you can force a time sync at Tab2 and the traffic will show up at Tab5. I had to try a few different time sync servers before I found one that would reply correctly.

As for the flashing to ‘identify device’, just experiment around. It should do ‘something different’ when you activate it. After a few seconds it will go to normal mode, whatever that was. The firmware needs to be fully up to date for this feature to work so check that please. If you’re not sure you can always use the status line down at the bottom of T3000 and watch the activity there. If you’re really not sure you can physically disconnect the device or power it down and see if that changes things.

Thanks, here is my Wireshark screen shot. I still get the error?

-Check that the gateway setting is correct in your T3 IP settings.

-If you are using DHCP check for rouge DHCP servers on your lan which can mess things up. Here’s a tool for tracking down rogue DHCP servers: https://www.tachytelic.net/2019/05/detect-rogue-dhcp-server/

-Try different time servers.

-I checked with our developers here and was (re) enlightened that wireshark is just capturing the traffic from your PC to the network. To see more detail of the traffic between the T3 and the time server you’d need a managed hub to mirror the T3 traffic out, here’s more on that:

-If you’re still having trouble you can let it sync to the PC for now. The on board battery will maintain time during short power outages.

-For reference, the T3 tries to sync with the remote time server once per day, it will try to sync up to 5 times and then stop.