Outdoor Temp & Humidity Sensor

Well I did it again… I went to update firmware and something went very wrong

I am good a breaking things… once again any help is greatly appreciated

Lance

Here’s a document which will help you unbrick a bricked unit.

https://temcocontrols.com/ftp/software/20T3000Update.zip

In short, you can power up the device and during the first few seconds after power up you can load a firmware image using the ‘ISPTool’ standalone firmware tool. its available from the T3000.exe -> tools -> update firmware for one device. You will need a copy of the firmware which you can manually download from here: https://temcocontrols.com/ftp/firmware/

 

I have tried several times and I am unable to get it to work. It always says programing failure or unit is off line. As you can see from last post I can ping unit. Thank you Lance

Is it Possible that I am selecting wrong firmware? I have the Weather Station and this is the firmware that the update first tried to install and I have been tiring to reinstall “CO2_HUM_RESSURE_REV24.hex” ? I apologize for all the inconvenience and do appreciate all the help. You don’t find many company’s that truly believe in customer service any more.

Once again Thank You

Lance

The outdoor weather station is a new product for us so that may explain some of the troubles you’re having. There’s also a chance that the firmware for this new model hasn’t made its way to the ftp folder yet and unfortunately my crew is off for the local Chinese New Year.

I’ll assume that the IP you show the device at makes sense and your PC is on the same subnet.

Using MBPoll, a modbus tool from within the T3000 -> tools menu you should be able to poll a few registers and confirm the unit is operating normally. Does the LCD show normal operation? If its not booting up and showing anything then indeed you’re dealing with a bricked unit which CAN be revived but its a little more complex as described in that earlier firmware update document.

You could try connecting over the RS485 port, if scan doesn’t find it you can use the same modbus poll tool to view a few registers, set the polling to broadcast mode, address 255 and it’ll respond. Then you can read the RS485 network ID at address 6 (base zero).

We can connect with you over teamviewer when the staff returns, Feb 23.

Standing by to help as best I can in the meantime. Send more screen shots and maybe I can pick something up.

 

 

Thank you Just a blank flashing screen. I am I no rush this is a great learning experience for me. Thank you for the help.

Thank you no great hurry this is a good learning experience for me

Hi Guys, I have been reading the forums and all is too familiar!

FYI, I also have the same issues and many other ones after purchasing 3 off T3-LBs and 2 off T3-TB controllers, 2 off PS sensors.

All 5 of the controllers do not work! ( That’s above $1,000.00 AUS dollars that I have given to TEMCO/BRAVO in exchange for 5 dead controllers! Hmm…Not really a fair deal , is it?

I have spent many hours and late nights trying to fix the problem via updating to the latest firmware, connecting via IP/RS485, also tried to view the Modbus register viewer… oh, but now that doesn’t work either in your latest software revision release dated, 8th February 2018.

 

I noticed you mentioned (Maurice) a " bricked unit " and " revive ". Can you please send me some documentation regarding how to revive a bricked unit as I would like to revive my $1000.00, if it works, that is?

I really think the BRAVO Product has some great potential as a competitor to the bigger guys out there, but if I didn’t have so many faults from factory, then I would be pushing the sales of this product very hard out in my industry/market.

 

 

 

Well in ase you missed it up there Adrian, here is the link for a document explaining how to get your controllers going again.

https://temcocontrols.com/ftp/software/20T3000Update.zip

In short, during the first few seconds after power up you can load a firmware image using the T3000 -> tools -> firmware update for one device tool.

You’ll need a copy of the latest firmware on hand which you can download from here:

https://temcocontrols.com/ftp/firmware/

I stand behind my products and will support you well till all is working as advertised. If you’d like to return the gear for a refund we can arrange that too.

Cheers,

Maurice

 

 

Hi Maurice,

Previous to writing in this forum I had already updated and installed the latest software version and was already aware of the power up method and had already tried that (many times) before writing my original message in this forum. I try to make sure that I have covered all bases before asking for help.

 

It’ll be best if we connect with you by email and teamviewer. Bricked devices can be recovered easily but it can be a tricky if everything is not connected and set up right. Please send an email to my personal email which I believe you already have. We’ll support you well and get those units back into action.

OK Maurice, I will get in touch with you soon and hopefully we can resolve these issues promptly.

Hi,

We have the same problem. But, the fimrware on ftp site is version 2.4. On controller is 2.8. Do you can make firmware 2.8 available ?

Have you been able to correct your problem ? I am looking for the same solution as you.

Charly is putting the 2.8 on the firmware update system now. Thanks for the heads up. Any other issues just let me know.

Hi,

I tried new firmware 2.9. But the controller not update with tool.
Network work, and respond to ICMP Query. Modbus Pool work and answer to query.
The lcd screen dont stop flashing.

This product has never worked properly. What can I do ?

[Admin: All gear gets a 24 hour burn in test so it was working at one point… from the description it sounds like you may have attempted a flash at one point during your testing. We’ll work with you to get it back in action.]

Patrick Bouchard

Do you have chat support ?

It would be nice

Patrick Bouchard

Yes, my skype ID is mauriceduteau and Charly in charge of this product is temco_charly.

Admin: All gear gets a 24 hour burn in test so it was working at one point… from the description it sounds like you may have attempted a flash at one point during your testing. We’ll work with you to get it back in action.

Answer : Yes, i received items and the controller working at this time, but on the first boot, lcd display no sensor. Also, no light in menu. I tried update firmware, but on your ftp server, the version was 2.4 at this time. You put version 2.9 at my request. So, It may have worked at your enterprise, but that’s not the case in my home.

I hope your collaboration to help me solve the problem that other people seem to have had too (see lp7734, first msg).

At my house it is midnight, it will go to tomorrow.

Patrick Bouchard

Well I have been busy and just had a chance to get back to my project and wanted to let everyone know that the new firmware download worked great and my weather station is alive! Thank you all for the help. I am sure as I keep working on this project I will have many more questions. I am glade that I found TEMCO because you all have been very understanding and helpful.