Node-Red and additional nodes Installation

This tutorial shows how to install Node-Red on a Raspberry Pi Compute Module to be used in a supporting Temco product. Node-Red is, as it’s web-site says “a programming tool for wiring together hardware devices, APIs and online services in new and interesting ways.”

The initial installation of the Raspberry Pi Compute Module can be seen here. In this tutorial I will show how to install Node-Red and setup additional nodes - the nodes provide additional functionality.

After installing the Raspbian OS, doing an update and upgrade - and enabling SSH, the Compute Module can be accessed remotely using Putty (or another SSH client). To find the IP address of the device I use Angry IP Scanner to scan my network and find the IP address, this could also be done by connecting a display to the device and using ‘ifconfig’ to display the network settings.

To install Node Red on Raspberry Pu the recommended method is to run the script - enter the following command to do this;

bash <(curl -sL

This will download the script and run it. It will ask for confirmation that you want to install first, and then ask if you want to install additional nodes - enter “y” for both and press enter.

Above image shows the installation - if any segments of the installation fail it is recommended to retry the installation.

After the installation of node-red has completed in order to run it each time on startup enter the following command;

sudo systemctl enable nodered.service

Then enter;

sudo reboot

to reboot the system.

Once it reboots you should be able to access Red-Node by entering the IP address of the Raspberry Pi in a browser (Firefox or Chrome are recommended) - followed by :1880 - ie - The following image shows the Node-Red user interface you will see in the browser.

In order to install additional ‘nodes’ click on the menu button in the upper right corner (3 lines) then select ‘Manage Palette’;

This will bring up the interface for removing or disabling existing nodes, or installing new nodes;

Click on the ‘Install’ tab and enter the name of. or part of the name of the node you wish to install in the search box;

Recommended nodes to install are;


These are the nodes that I am currently using to create the tutorials and user interface that I will be designing for use with Raspberry Pi enabled Temco products.

1 Like

Does the node-red-node-pi-gpio can work with pi compute module ?

Sorry for the slow reply on this - I have tried several times to get this working and I have been having a lot of problems getting the node-red-pi-gpio node to work with the compute module. I keep getting a “nrgpio.python command not running” error, and although I have tried all the solutions I have found to that error I am still not having any luck. I am very busy right now with several projects but this is on my to-do list so when I get back to it within the next few days I will update you on my findings.

Hi Brent,
Great work here though I am trying to work through this. I have followed all of the steps that I see. A bit confusing between your June 25 (and prior) files and the Master set of files.
I have loaded your recomended set


but I am still getting the following errors. Specifically I am unclear about where your files are supposed to land such as:


If we can get it all straight maybe we could also set this to a more conventional git structure where we see all the files in the folders that are to be used and be able to do a “git clone” or “git pull” type command to merge files in. Complicated but might simplify too. (I am not quite sure how we would send “a few” files into a preexisting folder tbh but I know we can.

the Errors I am getting are the following in Node-Red

Flows stopped due to missing node types.


I have worked through most of the above. Not sure still about “gate”… there seem to be hundreds with “gate” in their search set.

Some of which I installed include:

  • node-red-contrib-modbus
  • node-red-dashboard (second time it seems)
  • node-red-node-ui-table
  • node-red-contrip-later:later

(I’ll try a few “gates”)
This one likely it:

  • node-red-contrib-simple-gate


No “missing dependencies” now but I need to understand the following (I have not “deployed” as I get the following error:

* [HomeControl] Modbus Flex Getter (modbus-flex-getter)
* [HomeControl] Modbus Flex Getter (modbus-flex-getter)
* [HomeControl] Modbus Flex Getter (modbus-flex-getter)
* [HomeControl] Modbus Flex Getter (modbus-flex-getter)
* [HomeControl] Modbus Flex Write (modbus-flex-write)
* + 230 more