Managing and integrating devices over the Modbus RS485 port

Hi Maurice,
After the successful connection issue yesterday,
I have successfully read/write registers in the T3 controller both with TCP and RS485.

The final step is to assign the MODBUS ID to something other than 255. For example, 3.

When connected by ethernet, I go in and select the “Main RS485” serial port and set the com port on the laptop (COM3 in this case) and the speed to 19200. Save and reboot the T3.

Using either the MODBUS Tool or another Modbus test program on a second computer, I can only read registers if the MODBUS Slave address is 255.

Most maddening is that I can read T3 register 0006 and it confirms that the MODBUS Slave address is 3. Also T3 register 0019 shows that UART2 is set for 19200.

I have tried resetting , power up/down ; ethernet cable in /out, all to no avail.  

I know this has to work; I’m just missing some subtle point.


I think the setting you are looking for are here. If the device will be a slave only device then set it to slave like at Tab1 and if it’s a master, set it like at Tab2. Finally Set the device ID, this is the modbus ID. I can have the team change the wording here to make this more intuitive.


Thanks Maurice

Yes, that is where I made my settings.

In my case, I’m not using rs485 sub so it is unused and rs485 main is set to modbus slave.

Device ID is set to 3.

As noted, I can see these by doing a read of the registers. It just doesn’t seem to be adopted by the controller.

Thanks, I have asked Chelsea to check into this. Be sure you have updated the device firmware recently, several functions related to management over subnet connections have been done lately. Also check out the latest version of T3000, lots of good stuff done this week.

Hi Maurice,

I really appreciate the continued support! Getting good help so quickly makes working through a problem worthwhile.

After yesterday’s frustration, I went back this morning, without making any changes and tried reading registers with last night’s modbus ID of 255. No response.

So I changed the target modbus ID to 3, and behold! Correct data.

Is there a special sequence to save new settings?

I will also update T3000 and the firmware and try to recreate the problem to better understand the issue.

Got it going then, great news. I dont know what might have been going on before… and far as I know there’s no issues with managing the T3 gear and any of our gear in fact, over both the Ethernet port and/or the RS485 ports. There were some issues under Bacnet protocol a while ago but that has been fixed up in the recent updates. There was an update last evening by the way, plenty of good features & fixes in that so be sure to update T3000 as well.

Hi Maurice,

I'm reasonably happy with the system and can read the registers over rs485. The issue of not being able to get the T3000 software to connect over rs485 is still a mystery.

Just to summarize my efforts on the Modbus system:
1. Updated T3000 software and the firmware on the T3-TB.
2. I can now set the Modbus ID and read/write to the registers over rs485 or the ethernet connection.
3. Modbus registers can be read via rs485 with ethernet, rs485 or both connected.
4. HOWEVER, the T3000 software cannot talk to the T3-TB over rs485. When the Scan is invoked, the correct comport COM4 is selected, but “garbled data is reported”.

I’ve attached some screenshots for you to have a look at.
Starting with ethernet NOT connected and rs485 connected to the PC. Modbus ID is 7.

Click on Scan icon. COM4 is the correct PC port and the selected speed is 19200.

Try to do a Modbus poll.

Check for the correct selected building. Default building is correct.

Finally, plug in the ethernet cable and the input grid is correct.

Please update the latest firmware rev49.4, we already fixed this issue.

Hi Chelsea

Attached is the screen showing (I think) the firmware revision.

This was the status from last week.


Sorry, have to ask you update it again, in fact it was fixed on this Monday but the new version didn’t make its way to the firmware update system yet.

Hi Chelsea,

I reloaded the firmware to the device and now the the T3000 can identify both the Ethernet connection and the rs485 port.

Thanks for your work on this!