How to change baudrate on Airlab


I am having trouble setting the baudrate on an outdoor Airlab. In the T3000 software I go to the settings screen then change the baud rate to 9600. After a powercycle, I delete and re-add the device with a scan. The device reverts back to 115200 (Or possibly was never set at 9600)

I updated the firmware to 14.0 and my T3000 software is “Jun 21 2023 11”

I am using a RS485 dongle.

Seems like we have an issue on our hands. Lijun will dig into it with you first thing on Monday


I bought an outdoor and indoor Airlab. I tried the indoor Airlab this morning. It works fine. I set to 9600 and it stays after power cycle. This problem seems to be isolated to the outdoor model.

repair_bootloader_AQ.hex (110.8 KB)
It is due to that Airlab bootloader version is too old.
Download the hex file to your local computer.
The first step, update the firmware repair_bootloader_AQ.hex with ISPTool.exe in T3000 folder.
The second step, update main firmware of Airlab again.

That did the trick! Thank you! All working now.

I cannot get air lab to be scanned and found. It sees it as bacnet mstp device, but doesn’t show up in the results. I have 14.1 firmware on it and updated the t3000 software too. Is this bootloader still advisable to try? My bootloader shows as 80 when I use ISP tool. It seems I can run firmware updates, just cannot read any of the bacnet or modbus from this thing. Temperature is also 10 degrees F too high. I am thinking this batch has a bunch of problems.

If you can update the firmware, then your modbus is working.
Please post some screenshots such as the scanning results of the T3000 so that I can further analyze them. Also show us the communications health status line at the bottom of T3000, hopefully your network shows the connection health up near 100%.

Could you show us a screen shot or two of what you see from the T3000 UI please, perhaps we can pick something up from that. To calibrate devices, on most devices there is a list of inputs, you just add the single point offset in the ‘Calibration’ field and set it to + or – offset.

Thanks for support. I used to have the airlab working after changing to bacnet. But in hopes of getting better firmware and more accurate temperature, this is where I used the update features in t3000 apps. Now most of the time I do see it trying to send traffic as I can see on serial bus, but it says garbage. My cable is cat5e twisted pair about 2 meters long.
Should I try the bootloader provided above? Mine is at 80.
Here are

I reinstalled may T3000. Updated T3000 to Aug 7 again. I flashed this bootloader for AQ from this forum, and then flashed the 14.1 again. Still the same results. It sees something but does not go further. I would have expected after flashing bootloader and firmware that the persistent config should have been wiped out to only have modbus so I can configure the bacnet option again.

From your screenshots, it appears that your Airlab has been running the Bacnet protocol at 115200 baud.
I recommend that you use the Bacnet tool of T3000 software to change the Airlab protocol.
Tools->Bacnet Tool, click on the green plus ball, select the correct port and baud rate. Then click the “Add” button, follow the steps in the figure step by step, change “Protocol”'s “Present Value” to 0.
Then its protocol is changed to Modbus.


I don’t get to the stage of setting the source value prompt. It won’t connect to the device as shown in my screenshot above from yabe bacnet tool it says the output from the device is Garbage. I’ve tried many other baud rates, and all to the same effect = garbage on the terminal. This all started with the update button to 14.1 firmware.
apparently that bootloader now is only version 56. Do you have newer bootloader and firmware for the airlab? it came with 80, Things look like its worse, not getting anything out of this $170 box and i’m 3 weeks behind schedule.

We will assist you, please contact us by email for some live support. There’s no known issues with changing the Airlab baudrate and we’re confident we can get you up & running quickly.

Hi folks,

Do you have a newer bootloader? Originally the Air lab had bootloader version 80 when I used update in T3000 for firmware 14.1. From the bootloader on the forum, that one installs bootloader version 56. I think there is a conflict that it sends garbage data. I was able to get the present value changed to 0, but now I cannot get add into the bacnet tool anymore, but it looks like I connected in modbus tool. It still does not detect in auto scan.


I tried this All nodes dialog tool and it seems I was able to manually add, and now finally back to start. Do you have a newer bootloader?

Should I see ability to set trigger and alarm on the VOC and Particulates. I have the AL-CO2-TVOC.

You don’t need to update the bootloader, it’s used internally during the bootup phase. It switches over to the ‘normal’ mode a few seconds after bootup.

T3000 does not currently support VOC and particulate trigger and alarm Settings. We will add some settings for these things in an upcoming version. There is an update under way where you can add your own programming and generate alarms according to your own logic. It’ll be sampling in under a month.