Difficulty connecting to AirLab and Tstat10

When originally setting up the AirLab, using T3000 software, I got a connection and could see all the objects. Then something happened and now I can no longer communicate via WiFi or BACnet MSTP. Wireshark doesn’t appear to help at this point.

I know the IP of both devices:

When I run YABE it only sees the dot.140 (Tstat10) device. Originally it saw the AirLab device - now it’s not there. Clicking on the 178147 Device produces an error that it can’t fetch the objects.

I did a search over BACnet/IP.

2022-10-05 13_35_23-Temco Standard Bacnet Tool

But I still can’t see the devices.

No results.

I narrowed the search down to the device IP.

2022-10-05 13_49_04-Search

And got an error message.

2022-10-05 13_49_16-Error

I also turned off Windows Defender Firewall.

Later I connected the device by RS-485 - again no luck. Is there a way to reset the devices too original default settings?

I’m stuck. Any advice?

Mike Lavelle

You could try updating T3000, some older versions didnt cooperate well with Yabe as they both need port 47808.

When you scan from Yabe you need to select which network card you will scan from, your screen shot shows which doesnt look right, here’s the view from my machine, I will select the .15 card since the controllers are on this subnet. You could also shut down any auxilliary network connections like the VPN or wifi adapterif applicable just to keep things simple.

You tried connecting over RS485 and still ahd trouble so something is not right, are you 100% sure this is a known good RS485 converter and cable, you can connect to other devices using this same converter. Try connecting to one device only to keep things simple if you havent already done that.

Use the keypad of the device to change the protocol and baud rate to something simple like Modbus 19.2kbaud and give that a go. Do this with only one device connected to rule out the chance for an address conflict.

The only way to reset the devices to ‘factory’ is to flash the firmware, you can search this forum for ‘unbrick a bricked device’. Basically you cycle power and flash the firmware using T3000 → tools → flash firmware for a single device. Do this in the first few seconds after power up when the device is flashing teh backlight or heartbeat LED two times quickly, repeating every second or so. Only do this if you have exhausted all the usual troubleshooting steps. Do this with only one device connected to keep it simple. If you get part way through a flash update and have problems you can start again by cycling the power.

I updated to the most recent T3000.

When you say “network card” I presume you mean “IP Address” of the AirLab unit - correct?

My understanding is that IP scans all available IP addresses on the computer for a BAC0 response. I’ve seen this issue before (with Mango Automation) where scanning on a specific IP address fails - but I’ll continue to try both and

You mention “subnet” but I don’t understand the context of “subnet” since the AirLab unit on my main router, the same as my PC. Am I missing something?

When you say, “rule out the chance for an address conflict” I take you mean BACnet Device ID conflict. This seems unlikely but I’ll check.

I verified that I do not have a VPN running and that Windows firewall is shutdown. I also shutdown ZeroTier but still couldn’t see the AirLab unit.

I’ve ordered a second RS-485 - USB unit for testing. It seems to me that (surely) RS-485 MSTP will through to each unit - separate from over WiFi. Would you agree?

Just to sure…

YABE sees the simulator tool just fine.

But only if using (as expected since it does not have an IP assocated with it).

YABE search using

If I using my PC’s IP address

My PC IP Address - Second time

Finally, using my laptop’s IP address ( was able to display both devices - but only the AirLab would display its objects.

Still, I can’t display the AirLab device within T3000. It isn’t obvious how to do this. I can use Temco YABE to discover the devices. Do you have a video on how to use T3000?

What am I missing?

As I understand it, Yabe can find your Airlab just fine but T3000 cannot see it. I would disable all aux connections to the lan such as a wifi card if you have one, or any VPNs that may be active.
You can do that in the windows settings: Control Panel\Network and Internet\Network Connections

Update T3000, do that by navigating to T3000 → help → check for updates → update T3000.

Show us a screen shot of what you see when you scan with T3000, down at the bottom is the network connection health which is useful for communications debugging.

You asked above about an MSTP connnection, this is always required when first setting up our devices with Wifi only, use the MSTP/RS485 connection to enter in your network credentials.
If the device also happens to have an Ethernet port then you can also use that to set up the Wifi credentials.

You also asked above about subnets, in the context of IP addressing this basically specifies the ‘size’ of your LAN. Its a bit complex but assuming you have fewer than 255 devices your network likely has a subnet mask of /24 (bits out of a possible 32) which covers the range of say, - There’s lots of reference material out there to learn more about IP subnet masks.

T3000 now works and displays both devices over WiFi - but there are no objects for the Tstat10

Interestingly I updated T3000 again - although I had previously tried to update it several times. It isn’t clear that this update T3000 actually occurred - Help / Version History does not return any content.

I tried connecting RS-485 to the AirLab and Tstat10. Only the AirLab was found. (RS-485 connections appear to be valid - I checked with a meter.) Any suggestions?

I tried to change AirLab display settings

Update Display Settings

After rebooting the AirLab nothing displays on line 3 although Light was expected. I also noticed that there is no response when pressing Done. I expected the screen to go away - but nothing happened. Thoughts?

I also can’t get the Duct Mount AirLab to connect either. What is the range of power supply voltage each unit can accept? That is, 24VAC plus or minus what? Is there a pilot light of any kind on the Duct Mount unit?

T3000 software version “Oct 8 2022” is the latest.

According to your screenshot, you are using Bacnet MSTP protocol. Please set the communication protocol of Tstat10 to MSTP and try again, paying attention to any possible ID conflict.

The latest firmware version is Rev13.7, there’s a good chance your firmware isn’t up to date because the latest Rev13.7 firmware added this functionality. Please update your firmware using T3000 → help → check for updates → download firmware. Report back here if you are still having trouble after the update.