Airlab Baud rate resetting to default after power cycle

We have 3 Airlab AL-CO2-TVOC-W sensors that we need to connect to an existing Bacnet MS/TP network, we need to change their Baud rate to 38400. We are able to change the baud rate through T3000 and the device accepts the settings, however, once we power-cycle the devices they always revert to the default of 115200. All the other settings remain in the device, only the baud rate goes back to default. The firmware has been updated to version 13.5.

If you are using wifi to change baud rates it is possible that the packets were dropped, we have seen poor connectivity over Wifi which could explain this. Try making the change with T3000 and then force a screen refresh by leaving this UI and then returning to it (click on some other devices and view those for example). If the changes were written correctly then your refresh will show the correct baud rate.

I’m having the same issue with 5 of 6 Airlab devices. I can get them to use a 76.8 kbps baud rate through the T3000 software but when I remove the device from the backplate to remove the USB-RS485 adapter they revert to 115.2 kbps. It seems like each parameter of the BACnet MS/TP settings(MAC ID, Device Instance, Modbus/BACnet) results in a write to the device when that parameter is changed in T3000 but not Baud Rate. Is there a way to force that parameter change from T3000 after I’ve selected 76800?

I’ve updated T3000 and the devices have 13.7 firmware. Thanks

We were able to reproduce this and will fix it this week. Thank you

Were you able to find a solution? I’ve updated T3000 today(Oct. 28) but the firmware for the Airlab is still at 13.7 when I check for updates.
Thanks

We found that the bootloader of some products was faulty,This problem caused the baud rate to change after the device was rebooted。
Please use ISP tool and select repair_bootloader_AQ.hex ,click flash to update bootloader.
https://temcocontrols.com/ftp/firmware/RepairBootloader/repair_bootloader_AQ.hex

After that , use ISP tool and select Airquality_Rev13.7.hex , click flash to update firmware .
https://temcocontrols.com/ftp/firmware/AirQuality/Airquality_Rev13.7.hex

Completing the two steps above can fix this problem.Please ensure that the power is not disconnected during the bootloader update process, otherwise the device will turn to bricks.