Connecting subnet devices over BACnet/MSTP 485, misc Tstat7 debugging

Tstat7 Buttons: Sounds like the Tstat7 keypad is locked, the default is unlocked but perhaps with your experimenting you have managed to lock it. Please explore around in the T3000 user interface for the Tstat7 and see what you can see, if you have trouble you can email us or report back here.

Update: Our team did set up a T3 controller with Tstat7 x 4 pcs and 4 of the RTS-N room temp+setpoint dvices on a Bacnet subnet. The setup went smoothly but I do notice here that they all show as Tstat7 devices, more on that shortly.

Standing by to help out more as always.


could not get buttons released on Tstat7 with rev 11.3. flashed back to 8.9 and buttons work again. still won’t communicate with T3-BB on rev 62.9. shows up as MSTP but wont read and bacnet tool will not find it.
rev 62.9 tree

what are all the revision files you used on the successful test?

i’m doing all flashing over Ethernet and waiting until I get consistent solid pings. ping results seen random with a lot of non-echo 8 and 3 results. is that concerning?

After updating could we ask you to reload your latest config file. If the device hasn’t been updated in a while there could be a conflict between the old & latest configuration files.

Versions: We just use the latest and greatest version which you can always get from T3000 → help → check for updates → download firmware & update.

Pings: Ping is a very low priority task, many packets will be ignored because the CPU is busy with other high priority tasks. You can use it to prove a connection in general but don’t rely on it for testing the health. Its better to use the status line at the bottom of the T3000 window, there you can see the number of packets sent & received as well as the overall connection health.

Locked Keypad: After updating could we ask you to reload your latest config file. If the device hasn’t been updated in a while there could be a conflict between the old & latest configuration files.

can you give the exact revision files? i’m sure the sensors are old revision but the flash tool says they are up to date. I manually flashed one with CO2_None_rev35.hex. it now shows up on the tree, but wont read.

pardon my ignorance. How do i load the config file?

1 Like

I don’t have the versions but I can tell you that our tech who set up the test uses T3000 → tools → check for updates → download firmware and update device for all his updates.

i found some magic between revisions. i got the sensors and Tstat7 to scan in with the T3-BB at rev 62.2, manualy flashed the sensors to rev 35. and leaving the Tstat7s at rev 9.0

1 Like

Update: I had time today so I tried the latest Firmware again. rev62.9 still does not communicate to anything on BACnet. Scan Tool can not find any devices on rev 62.9. backed up to rev 62.7 and the room sensors and stat7s came in. will stay with this rev for now.

Tried rev113 for the stat7 again. still locks out all the buttons with no way to release.

willing to exchange any of my devices if you want to set them up in the lab and test them out.

I am not following the whole sequence of events there but our team can connect with you and help out on Monday. Send us an email with a teamviewer user/pass and we will coordinate a time for you.

I’m trying the 4 RTS and 4 stat7 on Modbus to see if they are more stable. so far results are positive. Only questions are the register lists. I can’t find one for the stat7, is it the same as the stat8?

Have you had a look through the modbus register viewer tool?


yes, the RTS show up but the Tstat7 says no register found. everything seems to communicate fine so far. And I have not seen one of the RTS randomly reboot yet.

I have asked Fandu to check this:
Tstat7 on subnet doesnt work with Register Viewer Tool.

any update on this? i might have to working Modbus if the RTS continue to reboot in BACnet.

Chelsea has the RTS working with Bacnet, she will do a long term trend log and show you the results with no resetting. Perhaps you can spot something from her setup.


The register list of TSTAT7 has been added to the latest T3000.
To use this function, please update the T3000 software

Thank you. The register viewer for STAT7 PID 93 works now.

I see your STAT7 is firmware version 11.4 and hardware version 22. where can I get that firmware? T3000 only updates to 11.3 and that locks out my buttons with no way to release. I have to flash back to 8.9 to get it functional

The latest release of Tstat7 is 11.3 . The screenshot on my screen is a test version in our office.
Your buttons are locked. You can change the parameters in the following figure.

I agree that should work but does not unlock the buttons. I have tried many times. Also tried to switch it through the register viewer. Nothing unlocks my button on rev11.3.