CO2 fail after update *new boot loader +v0.68 firmware*

T3000 v. Apr 9 2021 . 15

Few of my co2 sensors not working after update. This was bootloader update and firmware update to v.68. There is ping responce from time to time. I get this:

And sometimes ISP mode :

But after update same abnormal read!

Now T3000 thinks that CO2 sensor became T3 Controller?

Something interesting:

Something not right, many devices after boot-loader update fail to update firmware. Some co2 devices i tried 3-4 times before successful update.

2rd attempt:

Full update log of one CO2 device:


Thanks for all your work and feedback about the update. By the looks of it the update was successful. Our team will read through all the other posts and help out with any remaining issues on Monday.

I posted “regular successful” procedure of update. From part of sensors i updated now 2 are in ISP mode, and after update they restart in ISP mode again. And example i posted above is then i try to update sensor IP:.36 for some reason ISP tool is updating IP:.27, i guess this happens because, IP:*.27 is in ISP and it interfere with further updating my system. I think more similar issues will come out then other guys start updates. Also similar issues are happening then i already have new boot loader and try update from v 0.67 to 0.68, so this may be new boot loader issue.

Yes, when a couple of devices stay in Bootloader mode at the same time, these devices respond ISP Tool’s command when updating.This is the only way to prevent some devices from being stuck in Bootloader mode.
We recommend that you first update devices that are already in Bootloader mode.

I have a question. Are the two devices you mentioned restored to normal now? *If not, please update the firmware again.

I have 2 failed devices in 2 separate networks. One device is lost, no ping anymore, need to go on site to check it, before that it was in ISP and i tried update firmware many times. Second device was switched of from network i also need to go on site to check it, before that it was in ISP mode and i Updated firmware many times with no luck.

The reason for the network Ping timeout may be that the IP address of the device changed after the firmware update (if it is in DHCP mode).
What kind of mode do you use for these equipment?Static IP is still DHCP.

Equipment for handling lost contact
If the device is still in the Bootloader, you can open the T3000 and a pop-up message will prompt you to update the firmware of the device in about a few minutes.

The other situation is when the IP address changes, you can use the scan command of T3000, because T3000 sends a global broadcast, even if the device is not in the same network segment, you can find the device, and then use T3000 to change the IP address of the device to what you want.

I use static IP. IP is ok, device responding, it is in ISP mode, firmware is uploaded but after restart device goes into ISP mode again. That is only 2 devices. Actual problem is that for some reason only few devices where updated normally, most devices where updated only after many attempts.

You can give the firmware update a few tries. If you’re still having troubles you can connect over RS485 and update that way. Cycle the power and try flashing in the first few seconds after power on.