Bootloader Software

I was attempting to update firmware on a T3-BB. The message appeared that my bootloader firmware is too old. I have researched that I need to download the old ISP tool to update the bootloader. I tried…Recv BOOTP Byte Num = 300.
Anyone know how to get past this?

I am guessing this is the early AISX version of the T3 controller. The issue has been fixed some time ago, please update your T3000 front end.

Thanks Chelsea,
The 1st thing I did was update the T3000 software - before I ran the ISP tool. I was able to get through the process by connecting my computer to the T3-BB and the update worked. The customer’s computer was on the same subnet and when I was able to get the update started, it would get stuck at 1k and retry 9 times before programming failure.
When I connected my laptop and did the update the update worked?
On the customer’s computer I verified access through the firewall and insured that the T3000 had all permissions that I knew of. The biggest difference between my computer and the customer computer is mine is Windows 10 Pro - the customer computer is Windows 10 Home addition. I have been using the customer computer for two years and never had an issue. Job sites where I provide the host computer, I install Windows 10 Pro - so I only have one site (of course it’s this site) that has home addition as well as the AISX version for the hardware.
Any thoughts?

Hi Bret:
Please try to use the latest ISP tool for firmware updates, it is ISP Version6.1.3. We found that the old bootloader had some issues with the timing during power on and the start of an update, especially with the latest firmware images which are getting larger & larger.

This timing issue has been fixed in the latest Bootloader which gets automatically installed during an update these days for Arm based products.

For the older Asix based products, these will continue on with their original bootloader but the latest ISPTool can manage firmware updates with them.


1 Like

Thank you for the feedback Fance. If I have the latest T3000 software or update installed before I run the ISP tool, will the ISP tool be the most current or is there a separate upgrade for the ISP tool.
The procedure that I use is to update the T3000 software 1st, then I run the ISP tool.
It sounds like maybe I need to update the ISP tool separately?

ISP Tool will get automatically updated to the latest version if there is a new one. When you update T3000 you will automatically have the latest & greatest ISP tool which can deal with both the new larger Arm cpu firmware images as well as the early version Asix cpu’s.

1 Like