Fixing a Bricked Device: Older Asix based controllers

I had an interruption with internet connection during an update and now the controller just keeps cycling through the leds on the controller. T3000 LB.

Is there a way to unbrick the controller?

Thanks in advance…

The fix is to power cycle the controller and use the ISP tool to flash the controller. The power cycle places the controller into firmware update mode for approximately 10 seconds allowing you to then flash the controller.

I have a similar problem. T3-BB with ARM processor. T3000 downloaded a file (mini_asix_rev46.9_4.10.bin) and tried to upload it without success. Now controller is stuck in update mode (everything flashing). Tried to update with ISP - fails to connect to controller via ethernet - says file is OK. Tried to update using serial port - ISP says file is corrupt. How do I resolve this?

Just checked with the crew here, the ISPTool program should not have let you send an Asix file to an Arm board or vice versa. Once you update the firmware the checks will be done automatically to prevent this from happening again.

So for now you’ll have to update manually one last time. Download the latest Arm firmware from the link below, cycle power and then hit flash in the first few seconds after power up. The device should be flashing the LCD if it has one and the heartbeat LED, two blips repeating every second or so means it is in bootup mode and will accept new firmware from the ISP tool.

https://temcocontrols.com/ftp/firmware/T3_BB_LB_TB/mini_arm_rev46.9_4.19.hex

Once you have updated you will not need to use the ISPTool program any more, you’ll use T3000 -> Help -> Check for updates -> Download new firmware method.