TSTAT10 does not hold IP address

I recently received 2 new TSTAT10 thermostats.
I opened the ESP Apk on my ANDROID device and entered my WIFI password.
Device count = 1 and Selected Broadcast.
Powered up the new TSTAT10 and pressed confirm on the ESP Apk to commence configuring.
Result after many attempts was ‘EspTouch FAILED’
I then tried the second new TSTAT10 and same results.
I then noticed as I powered up the first Tstat10 again that it had an IP address scrolling along the screen. The IP address then dissapeared after 5 about 5 seconds and the ‘Configure WIFI’ message started to scroll across the screen again.
Both TSTAT10s have the same result.
NOTE: I didn’t have this problem 5 months ago when configuring the IP addresses of two other TSTAT10 stats via the EspTouch Apk. They had configured successfully.
Is what I am experiencing a Common fault within the newly released TSTAT10 thermostats?
Can someone please inform me with a FIX to this Fault as I need to have these two TSTAT10 stats operating by next week.

There’s a known issue with the early version of the firmware. You’ll need to update over RS485 this one time, from then on you’ll be able to set up the wifi and connect normally, including firmware updates over Wifi as well.


Thankyou Maurice, all done and working fine now!