T3000 IP address conflict question

I have two systems that have been operating wonderfully for 1 and two years. A couple of months ago, this changed.

One Host is Windows-11 and one is still at 10.
For both of these sites I am using Wi-Fi to connect remotely using VPN.

On site I am using a separate LAN/modem (with Wi-Fi for the TStat10 devices) for the T3000 systems. These LANs do not have access to the internet, the LAN is just a communication backbone.
The static IP for my LAN backbone is set to the setting that always worked before and is the IP settings in the controllers too.

Now, the T3000 software wants me to use the Wi-Fi IP base # which requires bridging the LAN to the Host Wi-Fi IP.
I’m not allowed to do this for these sites.

Is there a way I can tell the T3000 Host to allow me to decide which connection address scheme that works for these systems? I reinstalled and updated the software on both host computers and the controllers are also up to highest revision level. Same problem.

I can’t VPN into these sites and use the T3000 host software anymore. When I’m on site I have to disable the Wi-Fi to use the T3000 software. This makes updates impossible unless I bridge the LAN to the Wi-Fi which is what I have to do but I can’t leave them bridged.

Maybe this is due to Microsoft’s evilness because of their updates but Windows 10 and 11 both?

Any help is appreciated! :slight_smile:

A thread in the background of the T3000 software will automatically try all network adapters to communicate with the network device (such as tstat10-wifi) and record which network adapter to use to communicate with Tstat10. The next time when T3000 communicate to Tstat10, T3000 will use this network adapter directly.

There are currently no options for users to choose which network adapter to use. Right now, the T3000 is completely automated, which is for the convenience of some unprofessional users.

I would like to ask what problems you encountered while connecting?

I’m not sure why you’re not working on your end right now? Why was it possible before.
Happy to resolve this problem for you.

If your connection mode is only affecting firmware updates, you can try using T3000 to download the latest firmware and manually complete the update before finding the root problem and solution.

When I VPN in and run the T3000 software it locks up until it tries to get me to change my LAN ipv4 static setting to the Wi-Fi setting that is connected to the owners Wi-Fi. The T3000 insists that I stop using the the one that has always worked.

To update firmware, I remove the Wi-Fi modem from the LAN so only the routers are connected and then I change my LAN ipv4 to match the host’s Wi-Fi IP and then I wait until the T3000 software comes back and recommends the address change. When the change occurs I can then update the T3-BB.

The TSTAT10s are on the other Wi-Fi Modem so I have to turn off the backbone Wi-Fi so the TSTAT10 will communicate over Modbus.

If I disable the Host Wi-Fi adapter and then boot up the T3000, she works like normal. As soon as I turn the host’s Wi-Fi adapter back on the T3000 starts to have comm problems and then wants me to change the LAN ipv4 to the host’s Wi-Fi IP address. So I have to leave the adapter turned off or the host can’t communicate and the owners can’t access the graphics.

I always do the updates manually and I can always get updates from other sites and use a USB drive.
I found a workaround for updates anyway, I just can’t leave the Host adapter on and can only have it on to do updates.

Can you give me some screenshots? use cmd give me your ipconfig /all .
And I want to know the specific information of “VPN IN”
The graph below is the connection I drew according to your description. Do I have that right?

The PC is hardwired (ethernet) to the LAN, the LAN connects to the T3-BB, and two T3-LB. The tstat10 are wired Modbus and also connects to the LAN/modem’s wifi. The PC accesses the internet via wifi.

I will need to wait until tomorrow before I can send you IP config screenshots.

Basically, if I have the T3-host running with the host wifi adapter disabled, everything works. The T3 software doesn’t have any problems with comms. When I enable the wifi adapter, that has access to the internet, then the T3000 software determines that the host/wifi adapter IP config is what I need to use.

I have a rough idea of your connection mode and I would like to know if your Lan/modem, wired to the Lan, is on the same IP segment as the one connected over wifi.
You can also tell me the IP address information of all the network adapters on your computer.

I had a look at Fandu’s sketch of what is going on in the project. On his drawing, not shown here unfortunately, but it has two hubs both at IP - which is a show stopper. Every device on the lan needs a unique IP address including the hubs and routers if they are IP devices. If they are dumb repeaters (unmanaged hubs) then this isnt an issue but that diagram had two router or hub type devices both at the same IP which is going to cause problems.

Thanks for taking a look! I apologize for not getting back sooner but I haven’t had the opportunity to be at the job site and get the IP config screenshots that Fan_Du needs.

The LAN for T3000 is: (Gateway) and the computer that hosts the T3000 software is at: ???.254.?.? for the wireless connection to the internet.