T3-OEM connected to T3-TB via BACnet

I am having problem connecting T3-OEM to T3-TB-11I via BACnet/MSTP, the error is failed to initialized BACnet MSTP serial port information. Appreciate any help.

I would start out with updating T3000 as Tab1 and once that is done update the device firmware at Tab2. In older versions of the firmware you cannot update over Bacnet MSTP so temporarily switch to Modbus and separate the device from the main network and other devices to get started. Once you have a routine going you can update the whole network in one go but it’s best to start off with a single device till you have the process down.

DONE update of firmware, another issue this T3-OEM has no display even backlight, tried to set the LCD setting to LCD always ON.

thank you in advance

The important point is after power up, if the backlight flickers two blips, repeating every second or so after power up. That tells you that the CPU is working and the device is alive. If you don’t get the two quick blips on power up then there’s other things going on, normally a hardware issue.

If you were able to update firmware then that sounds encouraging. Try connecting over the RS485 port, since you can update firmware that means the RS485 port should be working.

The fact the LCD is not on, that could mean the LCD cable needs reseating. Give it a try to pull it out and push it back in.

1 Like

thanks Maurice, I am trying to pull it out but the display is seated tightly I am afraid it might break if I will exert more effort.
One more thing I can’t connect to T3-OEM in T3000 but in bacnet tool it ok

Correction by the way T3-OEM ordered was without LCD. So obviously there’s nothing to display. The other concern is I can’t connect this T3-OEM to my T3-TB-11i via BACnet, in BACnet tool it is okay. Any help is appreciated.

You’ll need to configure the subnet communications protocol and other parameters here in the advanced settings dialog. Connect to the subnet device first, the T3-OEM in this example. Set the baud rate and [protocol to bacnet on the subnet device. Then do the same with the ‘main’ Ethernet network controller, the T3-LB in this example.

Note: Modbus and Bacnet cannot work at the same time on the subnet so it’ll be best if you connect to each subnet device one at a time over RS485 and set the protocol that way. Once that is done you can add them to the RS485 bacnet subnet.

Hi maurice
i have the same problem, i have the t3-bb and connected to HUM-C over bacnet
and i’ve been navigate in the forum and try a lot of things, so i realize something
in my t3000 i do not have the local view in the tree just the default building.
is it got something to do with my problem? i have the last software version too

when i scan the HUM-C sensor with the rs485 dongle works well and find it.

Hard to say what is going on from your screen shot and descriptions there. In my screen shot here is where you can see what’s going on:
Tab1 Shows an online device and its red which means this is the currently selected device. All data in the right hand work area is coming from that particular device.
Teb2: This shows the communications health, you can see how many packets were sent and received by the device and the overall communications health. When you select a new device in the tree the counts will start again at zero.
Tab3: Shows a greyed out item, its a virtual device. You dont need these for the most part, you only use this if you are doing some configuring and setup offline and will load a program to the device later.

Tab4: Shows a device which was online before but its not detected now. T3000 will scan slowly in the background to keep this tree up to date. You can clear out garbage that accumulated in the tree by going to T3000 → database > all nodes > clear offline as shown further down at Tab5.

This is what i get when try to pull the hum-c bacnet device

this are my configure

i don’t know what im doing wrong
i update my t3000 and then the local view tree shows up

Lots of bytes coming into the subnet port and lots of bytes going out the main port. I think you might have the wiring to the RS485 port mixed up…

In one of your earlier screen shots up there you show yourself adding a ‘custom device’, you dont need to add any devices manually. When they are online they will show up in the tree.