T3-BB not seeing Tstat 8

As you know I have been working to put together something for a customer to control humidity in their location.

The tstat8 reads humidity, but doesn’t control it.

I got a Tstat10, but I am having problems writing programs to it. I keep getting an error.

I have a T3-TB, and thought “Ah! I will use the T3-TB to do the control, and connect the Tstat8 to read customer setpoints and space temp and RH, and do most of my programming in the T3-TB, which can be mounted in the AHU for best control!”


I cannot seem to get the T3-TB to see the Tstat 8. I have updated all firmware, tried setting the T3 485 ports to Modbus Master and Slave, have tried on both ports, for the hell of it tried BacNET.

But the T3 just does not see the Tstat 8.

What am I setting up wrong on the communications?

I can, however, connect to the Tstat8 via USB to 485 converter. Just cannot connect through the T3.

Humidity control is pretty straightforward, there’s an example showing a simple heating example in the T3000 help files. Its very similar with humidity control using a humidifier instead of a heater.

Tstat10: Show us what sort of error you are getting on the Tstat10 and I am sure we can help out.

Tstat8: Try connecting over RS485 and make sure the protocol and baud rate are set to match the settings in the T3-BB

You should be able to read everything on the Tstat8 and also write setpoints to manage the process.