Linking T3-LB to T3-866

I am having trouble linking a T3-LB to T3-866 via on board RS485 and have not been able to find anything in help of blogs to help. I assume I’m just missing something. I’m connecting to LB via ethernet just fine and can connect to 866 just fine via ethernet as well as RS485. I just can connect LB to 866 directly via RS485.

I’ve tried Main and sub ports on LB, tried swapping master/slave setups etc. LB is panel 3 and I set 866 to ID 2.

The scan tool will find both when I connect directly to my PC but will not find 866 as sub of LB. I also tried adding as expansion IO manually on LB but still no success.

As I mentioned, this is a prototype setup as I ultimately want to work with a BB to 22i setup but am waiting for them to arrive.

Could you show us the communications settings for the BB and Expansion device, they both need to be set to the same protocol and baud rate. Come to think of it protocol should e Modbus, not sure if we support bacnet for expansion IO actually, but that doesn’t really matter since all IO wll be available over bacnet on the Ethernet port.

The other thing to check is the expansion IO configuration screen, its under the advanced settings, I beeive there’s a tab of its own there. I can show a screen shot if you have trouble finding it. We did discuss the expansion screen ssetup on the forum somewhere so you can probably find some examples searching for ‘expansion IO’. I can have the team help in more detail if you have trouble.


Right now I’m using a LB, the BB is on order. I’m prototyping using LB connected to 886. Final system will be BB with 22i

I can access the expansion directly via ethernet as well as directly via modbus as well as bacnet 485 from my PC. I can also “sort of” access the expansion via the RS485 sub port using modbus via REG calls in the programing section. I can manually switch a DO on and off but I really want to have it act as advertised as a true expansion via RS485 from LB/BB directly not via ethernet (less reliable in my situation).

Yes, the expansion IO can be set up as you describe right over the RS485 subnets. The trick is to set the protocol to modbus and the baud rates should match between all devices. Then configure the expansion IO in the dialog shown.

Thanks. That’s exactly what I do but it never shows up. In fact many times it disappears and I have to redo?

Jeff Bonja


try updating the firmware of both devices. our team will check into this at the office and report back ASAP.


verified that LB is at 64.4 and 866 is at 5.8

The best way to check if there’s a new version is to just go ahead and go T3000 → help → check for updates → download firmware & update.

Fandu is off for a holiday so we’ll have to wait a few days for him to have a look at your screen shots and see if he can pick up anything.

One workaround is to use the Ethernet port and use the Bacnet instance and Bacnet object to refer to the expansion points. Check the ‘network programming’ topic in this forum for examples of that. Its not ideal though and definitely we will get you going with native ‘expansion’ referencing once the team has a look at what’s going on here.


  • I suggest you change the following configuration.
  1. Change the RS485 SUB port to unused.
  2. Click button “Clear Subnet Database”
  3. if still not work ,change the Modbus reply delay time ,change to 20ms or 50ms ,and have a try .
    Our firmware engineers will also update the firmware as soon as possible to make the connection of the device smoother. Thank you !

No success. Here is what I have tried.

Changed sub to unused
Tried to change Modbus timeout on 866 but only allows me to select 5 or 10 ms
Tried lowering baud to 9600
==> I am doing this on my lab bench so not sure if short link (1 foot) would cause an issue?
Tried swapping to Main

A few other items that I have observed:

  • Panel/sub panel window will not load. Not sure what it does?
    -The input and output points on LB stay as virtual
  • I tried clearing and reloading, clearing, rebooting, reloading
  • The network points window show 22 points for main panel 3 and device 10 (what I have mine set to). I can set DO via those points but cannot seem to read them (this may be my ignorance re how to use those points though). The network points go away when I delete the Exp module.
  • The expansion IO that I add disappears randomly. I add it, get the “success” popup, then go check other things, and then go back and its gone sometimes.
  • The scan never finds anything on the RS485 ports but works fine for ethernet.

Sorry to have you waste time on this for so long, I was informed by the team there is a known issue with expansion IO. Fandu will report back on Oct6 with a summary of the situation and shortly after with a fix.

1 Like

I’m doing additional testing and have run across another issue that may or may not be related. I am planning on addressing a Modbus device via the LB(BB) controller and cannot get the system to recognize the device. I have tried the following:

  1. both sub and main ports on LB at baud from 38400 - 9600 (both set to master)
  2. direct 485 from my PC via T3000 software (com3 via USB interface)
    This was attempted at add modbus under the T3-LB as well as Add modbus under local view outside T3-LB. I get a read data Timeout! error in all cases.

I can successfully poll the device via my pc using the USB Com3 test software though so link does work.

Please advise as I need this subnet off the LB(BB) to work for my design to work.

It could be some other software is taking control of port 502, the Modbus port. Be sure to shut down everything that could possibly be in the way. I have seen Niagara install a service which took over some ports in one tricky case. There was no program even running, just the service.

A serial port data capture tool can be helpful, we use a program called Docklight which is a paid version but there are many out there nowadays which are free.

Show a screen shot of the connection using our usual T3000 software, especially the status line along the bottom showing the communications health.

Standing by to help more.

I use CAS modbus scanner (below) as well as Ignition and both communicate fine with the device via Com3 on USB. using 9600 and modbus id 20

I double checked that Com3 is free and ran T3000. tried to add modbus via local as well as building (not via T3-LB) and got below in both cases.

Ah, now I realize this is the expansion IO points. There is a known issue with expansion IO which the team will be working on right after the break.

That said, your screen shot is a little strange. The expansion IO should show up in the tree under the subnet of the T3 controller along with any other subnet devices. However on your screen cap there it shows the device in the tree on the main Ethernet network, its as if you are connected to the device over Ethernet. Just make sure you are connected either through the com port directly, or via the T3 over Ethernet and not both at the same time. At least till this is sorted out.

Fandu will be chcecking in on this thread as soon as they return from the fall break which is Oct6.

Basically, yes but what I’m talking about here is what may be a separate or related issue. My expansion is there so I could check config and firmware but Ethernet is not connected, only 485.

As I was waiting on that issue to be resolved I moved on to trying to attach another 485 device to the LB via 485 with no luck. Also tried to attach directly via T3000 and my pc com port but also no luck. I know device and interface works as I have accessed both via 3rd party test tool and via Ignition through both modbus RTU and TCP.

The other device is a Datexel data logger with modbus interface and I’m using only for benchtop test. Ultimately I need to connect the LB to a chiller on my roof and the expansion module will be on my production floor about 50 ft away.

You have attached a Datexel data logger to the subnet network and you cannot reach the device over 485, could you explain how you tried to reach the device. I will assume you matched up the protocol and baud rate of the T3LB and the logger to exactly match each other’s settings. I also assume the parity and stop bits settings are matched correctly. I also assume the RS485 TX led on the T3LB blinks when you send packets out to your data logger but then you use no RX led for the reply from the logger. If all that matches what you see there then the only thing I can suggest is to send on a log of the RS485 data and we’ll see if we can pick something up from that.

Here are the setups of both LB and Datexel. I am connected to slave on Dat9000

When I run the scan I get below

I tried the built in modbus tool

With this setup. Device is Modbus ID 20, LB is 3
Screenshot 2023-10-04 080042
Screenshot 2023-10-04 080109

I also watched both the LB and Datexel TX/RX lights and they both flash… but there is a bit of a delay. the LB TX/RX flash together then maybe a second or two later both flash on Datexel

As can be seen from your screenshot it looks to be a problem with the settings. If the baud rate is matched correctly you can use modbus poll to access the subnet devices. Please make sure to close down any other software applications that may be accessing the subnet device at the same time, collisions will degrade the communications health.

As a background task the T3-XB will send RS485 packets to the subnet to discover new devices as they come online. The T3 will send a scanning command periodically and if there is a reply the device will appear in the T3000 left hand tree.

Here are some screen shots from a demo I did.
First check the serial port configuration of the T3 controller and subnet device. There are two RS485 ports on the T3 controller.
Check the network health dialog to see the packet count for each of the subnets. When the settings are correct you will see the packet counts changing here.

If settings are correct the subnet device will show in left hand tree.

If you are still having trouble you can send me an email to set up a remote troubleshooting session with you.
register3 (at) temcocontrols (dot) com

I am remote for the next few days so can only VPN into my desktop and have no physical access to the expansion io. I have everything set to 9600. per all of my below setup pages.
Expansion Module

The 485 device I’m testing

The LB I am testing (Note Main is for the 485 device and I’m using sub for expansion module)

And this is the health page. I also do notice bidirectional traffic between the 485 device and LB Main port on leds.

Note that nothing shows in the tree nor when I do a scan. I also have nothing except the rs485 from LB connected to the expansion (no ethernet or anything else).
The only software running is the T3000. I use the other programs only to diagnose that I can connect but then unload.