Linking T3-LB to T3-866

Baudrate of T3-8O should set to 9600, right? You should also confirm the modbus id of the T3-LB. Although the T3000 generates an alarm it can be ignored. The latest firmware for the LB is rev64.4, please be sure to update it to the latest version using T3000 → help → check for updates → download firmware & update. There are no major issues with the old firmware but its best to be sure by doing an update when you start any troubleshooting session.

Looking at your screen shots, the DAT9000 is your software which is connected with “Main” RS485 port of LB and the T3-8O is connected to the second RS485 'Sub network" port of LB.

Using T3-8o as expansion IO for the T3 controller is a common and well tested application for the '8o. As long as the protocol and baud rate are matching between the two devices and the Modbus ID does not conflict then the T3-LB can quickly automatically find sub network devices on BOTH the two RS485 subnetworks.

Could you please send me your connection diagram just to confirm everything, you can send that to any of the email address’s on our website and it will be forwarded to me. If necessary we can do a remote session with you using anydesk, we can coordinate that by email as well.

1 Like

I must really have something wrong on my end as I just received my new T3-BB as well as T3-22AI and tried to set it up and still same thing I had with my T3-LB connected to T3-866.

Here are my observations:

  1. I can connect to the T3-22AI as well as T3-BB via ethernet as well as RS485 using a USB to 485 adapter directly from the T3000 software.
  2. I can connect my other RS485 test device just fine via same 485 adapter as well as ethernet using their software.
  3. I cannot get the Main or Sub ports on BB to recognize the 22AI nor any other 485 device (ie the test device above). I had same issue with the LB and 866.
  4. I am using relatively short lengths (1meter) of shielded 20-24 AWG wire designed for 485 links. all end points are terminated with 120 ohm resistors. For this test its point to point. Ultimately I wanted to use main to connect to 22AI and sub to connect to two chillers.
  5. The T3000 software does crash quite often (running win 10 pro 64 bit on I7 1.8 GHz with 16 GB ram


  1. is there any network/system security settings that could be blocking the system from working? IT is very tight here and I have admin rights to my local PC but they lock down lots of stuff including network ports etc. I have not tried bringing in my personal PC to try all of this airgapped from the corp network.
  2. is there something unique in the physical connection that I am missing? Seems like my USB 485 device connects to everything with no issues.

Here are more screenshots in case I missed something.

Note I connected to 22AI via Ethernet just to config. I disconnect and delete from T3000 when I’m trying to connect through BB


1 Like

There’s a number of threads on this forum on how to set up expansion IO. Just make sure the firmware for all devices is up to date and that the protocol is Modbus with the same baud rate for all devices, Tab2. Then head to the expansion IO dialog at Tab1 and confirm which expansion devices you have. The RX and TX led lights on the RS485 ports should tell you if communications on the expansion subnet are working.

We’re standing by to help

I have to enter it manually and it usually disappears and I have to keep re-entering it. All else matches up. Modbus Master for BB, 19200 per the above screenshots. I did adjust Modbus ID to 10 as it seemed like the scan was taking a long time to get to 254 which was default for 22I

I do watch the. lights and to be honest they never sync up. I have tested reading the 22I via a third party Modbus TCP to RTU gateway and they sync up with it as well as send data just fine. Same thing reading the BB (set to slave) using same setup. It just seems like I cannot get the BB (Or LB) config as a master and recognize any Temco expansion module nor a 3rd party modbus slave.

1 Like

Could be a firmware update issue. Show us the two communications settings dialogs please, the one for the T3BB and the 22i.

When the buad rates, protocols, parity and stop bits are all in sync you should see the RX and TX leds doing a good job of showing the packets moving around. If not then there could be settings out of sync or modbus ID conflict or… hard to say what. Do make sure the firmware is up to date for all devices.

1 Like

I believe I checked all of the firmware as well as T3000 software but here are all of the screenshots.
Physical setup. BB is on network ID 1. 22AI is connected to BB via Main RS485 ID is 10. Another Modbus device is connected to Sub ID is 20. (screen shot shows it as slave as I tested accessing BB via the other modbus device and it worked fine in that direction, normally I will connected as BB master and modbus device as slave.)

Again this was captured when I temp connected the 22AI to the network then disconnected.

One update from today. I was playing with the 866 module I have and had just disconnected it from the ethernet after checking the settings. Somehow it was recognized by the BB and showed up as a proper sub panel… outputs and inputs showed up on main BB pages as Id expect and it was connecting via the 485 link. I then tried to do the same with the 22I link and poof nothing… only clue was I rebooted the BB just before the 866 magically showed up. There was tons of traffic per the TX/RX lights then nothing.

1 Like

The controller maintains a database of the devices in the neighborhood. Things can get complex what with Ethernet and two separate RS485 ports on each device. The best way to sort things out is to make sure the firmware is up to date and only use one of the connections at a time. The database will get refreshed over time in the background, and you can clear the database manually, there’s a button in one of the UI’s but I cannot recall where it is off hand.

Update: here is the button to manually clear the subnetwork devices