General Ethernet Questions

In my situation the Ethernet port on T3-BB is not active so my PC reports ‘Cable is unplugged’. I see that all outputs LEDs are blinking from the first to the last and beat LED flashes by two times.
So it seems that the only solution is to use EEPROM programmer to flash it. Am I right?

I am not clear what you mean here Philip. The only way to flash firmware is to use the ISPTool and flash in the first few seconds after power up. You can see the procedure in the other thread which is now locked, we can continue here if there are more questions.

In my case the Ethernet interface on T3-BB is not working at all. On the other side of Ethernet cable my PC reports: “Cable unplugged”. Before deadly flashing Ethernet interface worked perfectly on this T3-BB. So I can make a conclusion: the Ethernet interface enables in boot up process and since I flashed an ASIX version with an ARM firmware it cannot be enabled.

Could you please provide the HEX/BIN file to write it directly to memory chip of T3-BB?

You can download the bin file by using T3000 -> help -> check for updates -> download firmware.

Maurice Duteau

my T3-BB controller is bricked.
I have used all of the fixes I found in the forum.
Nothing works.
I sent Candy a email to find out how to proceed.
Please let me know if anything has changed in the unbricking proceedure.
Thank you,
Steve Bowling

Hello Maurice,
Can you please tell me how to proceed to repair and/or replace my T3-BB-32i WIFI that has been bricked.
It occured when I tried to update the firmware using the ISP tool.
I have tried all procedures on the forum that I can find.
Thank you,
Steve Bowling

Same procedure as usual, cycle power and flash in the first few seconds after power up. The heartbeat LED should be blinking with two blips, repeating every second or two. If it doesn’t power up with the two blips then we’d have to get the unit on the bench for a checkover.

While the unit is powering up with the two blips you hit the flash button in the ISPTool as shown at Tab1. Fill in the path to the firmware file at Tab2, if you don’t happen to have the firmware file from some earlier updates you can download it manually here: If you’re connected over Ethernet you fill in the IP address at Tab3. If you don’t know the IP address, T3000 will detect a device in bootloader mode by scanning and present a popup where you can flash the firmware with one click. If you are having trouble to connect over IP you can give it a try over the RS485 main subnet port and filling in the connection parameters at Tab4.

Standing by to help.


Thank you Sir for your quick response.
I have fixed that problem and now I am on to trying to get my touchplate lighting panels online.
I’m I have them tied to the Master mstp connection.
I can see the panels but can’t read any of the points… yet.

You can send an email to info(at)temcocontrols(dot)com and we’ll arrange for the unit to be repaired.


When you’re having trouble to update firmware over Wifi it’ll always be best to revert to the wired Ethernet connection first. If that doesn’t work you can revert further to an update over the RS485 port. Let me know the nature of the heartbeat LED, during power up is should flash with two blips repeating every couple seconds, then 30 seconds or so after it should go to one blip per second or so.

There’s a few posts in this forum about firmware udpates, you can search for keyword ‘brick’

It sounds like you are integrating some Bacnet lighting panels into an MSTP Bacnet environment. Send on a few screen shots to confirm and maybe we can spot something. Standing by to help.