Tstat-8 connected to T3-LB

I have a Tstat-8 connected to a T3-LB and am having troubles:

  1. I can’t read the CO2? I may need some schooling…
  2. When the Tstat-8 is connected to the Sub 485 as Modbus, I can’t see the inputs on the T3-LB? If I disconnect the buss then I can see the input section but I lose it when I reconnect the sub net. The last screenshot is with sub net disconnected.
    Here are some screen shots:

Item1 regarding the C02 reading, that was fixed a few versions back on the Tstat8, please update and C02 will show up.

Item2: Viewing the IO, looking at your screen shots here all seemed OK. When the T3 is selected and showing red in the left hand tree and inputs are selected from the top menu, you see inputs of the T3 module in the grid area.

When the Tstat8 is selected & showing as red on the left hand tree, and inputs are selected from the top menu, then you see the inputs of the Tstat8 device in the grid.

Thanks for the feedback Maurice.

Item 1 - I did flash the latest firmware from the ftp/firmware site. I’ll check again.

Item 2 - The screenshot shows that I have selected the T3 and yet the inputs showing are from the Tstat8.

The last screenshot shows the only way I can view the T3 inputs is if the Tstat8 is disconnected.

Here is the scenario: When I power up the T3 and Tstat8 and then do a discover, I can click on the T3-inputs and the inputs show up correctly. If I click on the Tstat8 to check on it or make changes to it’s settings, then when I click back on the T3 to look at things…everything displays correctly, except for the inputs. To get the inputs back I have to disconnect the Subnet, reboot T3 host software, do a discovery and then when the Tstat8 is gone I can display the T3 input screen. Under normal operation, the problem begins when I click on the Tstat8 and try to return to the T3 input screen…I will only see the Tstat8 input screen. I have tried this on two different T3-LB controllers. I haven’t tried this on the T3-BB yet but I will as time permits.

Hope this helps some…

UPDATE! I just updated the T3000 Host software and the issue I was experiencing is corrected. The inputs now show correctly…always. :slight_smile:

And item 1, your C02 sensor reading showing up?

Item 1 the CO2 sensor - I used to see the reading on the display but now I don’t.
I also mapped the Modbus register of 139 and I do see 400 ppm but it never changes when I breath on the stat. The latest software rev on the ftp site is: [Tstat8_Rev7_1.hex].


Any reasonable readings showing on the display Bret?