CO2-N Connection to a modbus Master

I am having trouble connecting a CO2-N via Modbus to an Schneider m241 PLC. I have also tried connecting to the CO2-N with a generic Modbus software using a USB to RS485 converter. The only way I can connect to the device is with the T-3000 software, or the Modbus tool again using the USB to RS285 converter. I used the connection settings from the Modbus tool to configure everything (baud rate, parity, function code, ect…). I have set the CO2-N to a device address of 201, and a baud rate of 9600.
I have previously been using the CO2-W with Modbus in all our previous projects with no issues on the same m241 PLC.

The logs from the generic Modbus software state
10/16/19 12:02:02 - Slave ID = 201 - Fragment received, timeout waiting on a complete/correct response
10/16/19 12:37:52 - Slave ID = 201 - Timeout waiting on a response
10/16/19 12:42:08 - Slave ID = 201 - Exception response received - type 128

That “Fragment received” message sounds like a problem at the framing level, all our gear is set to use 8N1 message format, both the CO2W and also the CO2-n devices use 8N1. I know we put in a register for setting the parity for 8E1 on some products. Possibly the Co2N doesn’t support this properly. Let me know how you have things set up, do try on 8N1 if you can and report back. We’ll add 8E1 to this product if that’s your only option.

Thanks for all your work with the products.

Maurice

Thanks for your reply,
I have tried both 8N1 and 8E1. In 8N1 the Comm light on the CO2-Node would blink, but it would not transmit anything that could be read.

I have asked Lijun to connect up a unit and see what he can see. We have a 3rd party tool called Modbus Poll, we’ll try with that and report back shortly.

image001.jpg

Hello, I had tried using baud rate 9600 with T3000 and another 3rd party Modbus application called Modbus Poll. I set the set CO2-N modbus ID 201 and all works well from both T3000 and the MBPoll application.

Could you try again with broadcast address 255, the device will respond to a broadcast.
Try some other baud rate settings.

With our equipment we can only address 1 … 247. I have also tried with a baud rate of 9600.

Here is a link to a modbus tester made by square D this software is for debugging modbus devices connected the M241 PLC we are using.

https://www.schneider-electric.us/library/SCHNEIDER_ELECTRIC/SE_LOCAL/APS/209280_3412/Tester.exe

Lijun is checking this for you now. Stand by for news shortly.

image001.jpg

What happened with this test? I also can not see the co2 temperature sensor outside of the T3000 application.

The team is off for the local holiday till Feb2 but please do give it a try with doing a firmware update. You can do that using our T30000 software which can be downloaded on the product page. Then go to T3000 -> help -> check for updates -> download firmware & update. I know there’s been a lot of advances lately for new options on communications settings. You can update over RS485 or Ethernet.