Can't interface with Modbus devices via T3000

Hello all,
I have a T3-BB with a Modbus-enabled chiller connected to RS485 Main. I can communicate with the chiller and read/write all registers using the Modbus Poll program, but no program I write in T3000 will result in a response. I’ve tried:
VAR1 = 2.1.MB_REG202
VAR1 = 2.1.MB_COIL202

I’ve tried different panel numbers as well.

All result in Network Points showing the called register but with no value and it never updates.

What am I missing here?


Your best bet is to get a logger going like wireshark or others depending on if its RS485 or IP. Once you have exhausted the efforts with that you will need a hardware tool like an oscilloscope for RS485 or other specialized tools for Ethernet.

Standing by to help…

Thanks! So I guess I’m not understanding, what would I be checking with these tools? I can connect and communicate with the equipment via the Modbus Poll program so the link (T3000 computer → Ethernet → T3-BB → RS485 → Chiller) is working, if the T3-BB can’t communicate itself then I assume it’s a programming issue?

I’ve noticed reading other posts that generally holding registers start in the 40000 range and the software automatically adds that to any registers entered, however this equipment uses addresses starting at 0 instead (or at least, that’s what I’m polling via the Modbus Poll software, I don’t know if it’s adjusting its range to compensate), could that be part of the issue?

T3-BB can be used as a TCP-TO-RS485 converter in transparent mode, all modbus packets will pass throgh the T3 device without any special porgramming. This is how the MBPoll application will work to read & write from the chiller on a subnet. Additionally, the T3-BB can read subnetwork devices throught its own programs, do this when you want to do some processing on the data such as logging and alarming.

Modbus can only handle (smootly) one master at a time. So if you are running a program on the T3-BB to poll subnet devices it is the master for that particular subnet. When you simultaneously run MBPoll the PC will be acting as another master at a lower priority so you will loose the occasional packet.

Reading about multiple masters gave me an idea, and I disabled the other serial port (and zigbee port, it’s an older unit) on the T3-BB. I was finally able to read a value from the software! Is only one serial port serving as Modbus master supported? I don’t see anything about this in the documentation or in the forum, though I may have missed it.

Also, I’ve been having an issue where Zigbee keeps resetting to “Modbus Master” despite me setting it to “Unused” in the settings; every time it does this, I lose connection over the serial port. How can I permanently disable this?


You can use two Modbus ports both as masters, no limitation with that. You can only have one Bacnet MSTP subnet though. If you are seeing strange behavior be sure you have updated the firmware lately.