Bacnet Objects, High Address over 255

I’m trying to read from a Bacnet device, an analog value from addresses in the 400’s. I can see them fine using the Bacnet tool, but not when querying from T3 controller. I have no problem seeing other AV addresses from 1 to 50 using the T3, it just seems to be the ones in the 400’s I cannot read. Any thoughts?

Yes, with some earlier versions of the firmware we supported up to a maximum of 255, now the system supports Bacnet objects up to 2047 as of firmware version rev51.8. Please update your devices by going to T3000 -> help -> check for updates -> download firmware and update.

Thanks and standing by to help if there are any other questions.
Chelsea

Thanks Chelsea, I cannot update firmware from my remote connection for some reason, but next time I’m on site I will update the firmware.

Thanks for the quick fix!

I just updated the firmware, same issue as before, I can read AV401 using the Bacnet tool, but not with the T3.

I used firmware version 51.8 and the result looks OK, here I am reading bacnet device instance 668668 and object AV400 and its working well.

image

I’m not sure what I’m doing wrong here, maybe you can see something obvious? I’m still not reading it for some reason.

image
image


Thanks for your help!

Nice. I see you have figured out the mechanics of network programming and debugging. There’s lots of data passing around there except for the last few in the table. I suspect the MSV is not handled well on our end. Chelsea will work on this tomorrow.
Thanks for your great troubleshooting Chris.
MD

For IP points we tested and its working well but for RS485/mstp points I can see there is a problem. We need to set up a test environment here, no products on hand have objects up in the 400+ range. I have done a small test update with firmware rev51.9 which you could try downloading using the usual firmware update system. I will check more on Monday if there are still issues.

Thanks Chelsea, yes I’m communicating over the RS485 for Bacnet. I will try my best to get to the site to do the firmware update today.

UPDATE: I updated to firmware 51.9, but still no luck.

Sorry about this but we need a bit more info, if you had a wireshark capture that would help. If you can send a device here we’ll work from that and send it right back.

Chelsea: See if you can fine something here to test with. Simulator… ?

The device I’m talking to is a 400 ton chiller, unfortunately there’s no parts on it I can send your way to test. I see I can get the same statuses using a multi-state variable which has an address in the single digits, does the controller support multi-state variables over RS485 Bacnet? The response I’m looking for from the chiller is a simple integer number that I can enumerate to a status on my end. The next time I’m on site I will try and do a wireshark capture.

Thank you both for your efforts!

I see the issue, we need to add a new keyword in our ‘basic control’ language to pick up a value from an MSV this has been added to the todo list.

I am not sure if this is an option for you but if you can get the data you’re interested in into an AV you can read that using the AV keyword.

10 VAR1 = 3333AV20

Where 3333 is the Bacnet instance of the chiller and AV20 is the analog variable storing the data you are interested in.

Thanks Maurice, the data is only available in AV401 or MSV1 and I don’t have any way to change that - I look forward to having either of them accessible with the T3 controller.

Many thanks for your assistance! Love the products!

Please update to rev52.2, you can now read bacnet objects up to 2048.

Thanks Chelsea, I can confirm with 52.2 I can now see the Bacnet objects in the 400’s. Many thanks!