How to control the modbus polling frequency

Hello,

I have not found the tips I was looking for in the forum page, so I ask if you can help.

For a simple program like the following one, I can read modbus registers, but the RS485 Sub leds are always blinking like the TB is continuously communicating with the slave.

10 TEMP = 3.10.MB_REG37
20 HUMIDITE = 3.10.MB_REG38
30 REM WAIT 00:00:10

Even when using the WAIT or INTERVAL command, the leds are still blinking continuously instead of blinking one each 10 seconds.

Also, sometimes the RS485 Sub configuration is turned automatically to Slave Mode, I have to put it back Master Mode.

Excellent question, we have been asked about this a few times now. In the system as it is now, the T3 controller polls when it has time between its other tasks. It will be helpful if there’s a default as we have now, so folks dont have to think about it, but also a setting to those who care about these things. We will add this to the todo list for the near future.

After you set T3 to Master mode, other Modbus devices on the RS485 Sub port are also masters and send read and write commands to T3. At this time, T3 will automatically change its Sub port to Slave. Then other devices can read and write T3 normally. If you are sure that you are fixed as Master, you can write the 91 register of T3 to 1.
In general, the modbus bus cannot have multiple masters. Please confirm that there are no other Modbus Master devices on the bus. Make sure there’s only one Master.
In case there are multiple masters on the RS485 bus, you can force T3 to be set to Master by writing T3’s register 91 to 1.

Fandu we need to merge master and slave to one single MODBUS setting. same for bacnet. get this done ASAP please.

Maurice