Ethernet Scans in latest T3000

Somehow both of my laptops updated to the latest T3000 (July 4, 2024 version).
Unfortunately now the Ethernet Scan process has become unreliable.

If I “restart T3000” then I will have a Scan that finds controllers… However, often the search goes on and on. Right now I am seeing that it found 6 controllers, and shows 5 replies.

If I “exit” I get the list of all 6 controllers.
If I search again" I get Ethernet Scan 0 and Wait. Reply = 0.

It seems the previous search which I exited may still be causing the delay in the background. I am not sure. When I go back to T3000 it shows “nothing found”.
If I repeat, again, Ethernet Scan, 0, and Wait. Reply = 0 Again, “nothing found”

If I exit, then start T3000 again, Start Search again, It finds 6, Shows 5 receive reply.

But the search goes on and on… Basically does not end on the Ethernet line.

Older versions of the software did not have this issue. I don’t know how to revert except to uninstall, then reinstall but I have pretty old versions. The latest install I tried to use from a download link was giving an AVG t3000 idp.generic flag… so I had to install a considerably older one to start.

Ethernet Scan is still “running”… Might be 10+ miniutes in now. Anything I can do besides “exit” now then “restart the software”. Trying to configure a number of T3-ESP boards so ethernet connectivity is important.

The ethernet part of the scan only takes a few seconds. then t3000 goes into the serial ports with various settings to search for devices there. this is the part that takes a long time.

You could speed up that part of the scan by disabling any ghost com ports you might have lingering on your system.

While you’re at it you can temporarily disabled any extra LAN connections like vpns, wifi and virtual box ports you might have on the system.

You can also delete any misc devices that have been scanned over the years and cached in your database config files. Starting from zero devices may help speed things up.

We’re standing by to help out.


I’ll test again. Was a two pronged issue.
First scan would find the Ethernet connected (and some sub bacnet controllers) under Ethernet… but would never finish the Ethernet scan.
Second Scan would not find nor finish in the Ethernet scans.
As I noted this was after a T3000 update.

Let me get back to the test bed.
Referentially the main subject (fan controllers) were working very well.

My experience has been the COM on the PC take all the time, they go through many options of baud rate, network ID and protocol for each com port on the PC. My current test has only one com port on the laptop, the COM port scan went very quickly. There is one T3 controller detected and now the RS485 subnets scan is taking a long time. There’s not much that can be done to speed that up, it has to try each baud rate, network ID and protocol on the two RS485 subnets.

Correct. Com scans are not fast but they are completing.

It is the Ethernet scan which is not completing (First Green box in your image)>
As I said, I will test again and also with a few laptops. Basically came up with the July 4 update that hit both laptops simultaneously. I was trying to keep one back but the process of “check status” or something under Help forced the same update that "Update T3000 did).

I have noticed that the ethernet scan can get lost in the weeds if there are multiple ethernet connections on your laptop. For example, hardwired on one subnet, WIFI on another. I suspect it has to do with resolving networks vs using the gateway. I don’t know if this is applicable in your case but I have found disabling network adapters helps.

When you are having troubles with the scan, definitely the first thing to try is simplify your network environment. Shut down any VPNs, virtual machine adapters, wifi and bluetooth connections, as appropriate. Once you have the connection sorted out you can re-enable these aux connections.

I just tested the network scan and its working well. If you are still having trouble you can tell me more details such as which Temco and Non Temco devices are on the network. Make sure all temco devices have the latest firmware as some devices from ~2 years ago, we did see some broadcast storms under certain conditions.

Thank you for your feedback.

So the same result again. Basically not completing. It could be related to
Devices Found : 5, Receive Reply: 4

If I exit, I will see all 5 Devices and can connect to them.
If I scan again, Ethernet Scan is just “waiting”.

July 4 T3000. Was working before the upgrade a few days after July 4

Need to run now, but I did test this also with an Isolated (non internet connected) network and had the same result.

If you could send a couple screen shots and wireshark logs perhaps we can spot something there.

Also be sure to temporarily disable all ghost and auxilliary COM ports and Ethernet adapters. On my machine, when I have troubles scanning I end up disabling the VPNs, the virtual pox adapter and the wifi adapter. Once you have things working as expected you can gradually re-enable the ports.

Fandu’s test in the office with a fairly busy ethernet environment, 10+ devices and another 10+ subnet devices, this has been going smoothly.

We’re standing by to help more.